bad graphics on psx emulator

Welcome Page Forums RetroPie Project Video Output on RetroPie bad graphics on psx emulator

This topic contains 10 replies, has 2 voices, and was last updated by Profile photo of izhar izhar 2 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #96570
    Profile photo of izhar
    izhar
    Participant

    Hello all
    My project for Retropie with rpi2 and Berryboot go to the end. Now, i makes the settings.
    Megadrive and snes works perfectly, but the psx, no.
    I think, the shader isn’t use or maybe a problem with upscaling ?

    Can you check the attached files and say me if you have an idea of my problem please ?

    I’ve change shader (h2xq, h4xq, video_smooth, etc …)

    the better will be less pixels and no lines ^^
    Thanks

    Attachments:
    #96833
    Profile photo of izhar
    izhar
    Participant

    Hello, anyone has or had this problem ?
    thanks

    #96909
    Profile photo of patrickm
    patrickm
    Participant

    PSX graphics were very complex and designed to be displayed on a CRT. The sharpness of an LCD can make some of these graphics brutal to look at.

    Not all shaders will work with the Raspberry Pi. Try the “crt-hyllian” shader in /shader/crt/crt-hyllian-glow/hyllian.glsl
    (under options -> shader options)

    make sure your scaling is correct. Set RA render resolution to 960×720 and keep your monitor at its native resolution. Hold “x” when launching from Emulationstation to bring up the menu to change this.

    Set aspect ratio to “core provided” or “4:3”

    set integer scale on (under video settings)

    set crop overscan off (under video settings)

    that should be all you need. If CRT-Hyllian is too heavy for your taste, try CRT-caligari instead.

    also, you might try a different graphics plugin (under options -> core options)

    #96990
    Profile photo of izhar
    izhar
    Participant

    hello
    in shader, i haven’t CRT path.

    /opt/retropie/emulators/RetroArch/shader/

    it’s right ?

    #97141
    Profile photo of izhar
    izhar
    Participant

    Hello
    Iv’e try to other games, it’s not very good but no lines.
    on tekken 3 and few games, lines always.

    in my retroarch.cfg in “all” :

    
    video_smooth = true
    video_threaded = true
    aspect_ratio_index = 6
    video_scale_integer = true
    rgui_show_start_screen = false
    

    in retroarch in “psx” :

    
    video_shader_enable = true
    rewind_enable = false
    video_smooth = true
    

    Thanks for help

    Attachments:
    #97147
    Profile photo of patrickm
    patrickm
    Participant

    hello
    in shader, i haven’t CRT path.

    /opt/retropie/emulators/RetroArch/shader/

    it’s right ?

    It should be there if you used the Retropie setup script. If not, you can download them here:

    https://github.com/gizmo98/common-shaders

    #97148
    Profile photo of patrickm
    patrickm
    Participant

    Hello
    Iv’e try to other games, it’s not very good but no lines.
    on tekken 3 and few games, lines always.

    in my retroarch.cfg in “all” :

    
    video_smooth = true
    video_threaded = true
    aspect_ratio_index = 6
    video_scale_integer = true
    rgui_show_start_screen = false
    

    in retroarch in “psx” :

    
    video_shader_enable = true
    rewind_enable = false
    video_smooth = true
    

    Thanks for help

    What is your video output resolution set to and what is retroarch render resolution set to? Hold down x or m when launching a game to bring up these options.

    #97183
    Profile photo of izhar
    izhar
    Participant

    hello
    960*720, i’ve set it in retroarch.cfg (path “all”)

    #97686
    Profile photo of izhar
    izhar
    Participant

    hello
    It’s the good resolutioon i think ?

    #97729
    Profile photo of patrickm
    patrickm
    Participant

    hello
    It’s the good resolutioon i think ?

    You will get scaling artifacts with that setup if using a 1080p display.

    See “list of recommended resolutions” and “how to get scanlines”

    Sorry for contradicting myself, but I’ve learned recently that shaders aren’t optimal for the pi.

    #97770
    Profile photo of izhar
    izhar
    Participant

    ok, thanks for your answers, i search it with your recommandations 😉

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar