Atari 9-pin Controllers won't go UP or LEFT – fix enclosed for compiling :)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Atari 9-pin Controllers won't go UP or LEFT – fix enclosed for compiling :)

This topic contains 3 replies, has 3 voices, and was last updated by  ervine 2 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6757


    Firstly, and again, thank you to the developer for making RetroPie exist. I have had a really nostalgic and fun time with my project “Apple Piie” (see my other thread) and almost everything is working now as it should, with a few exceptions.

    As you may know, there is an issue with all the popular Atari 9-pin joystick > USB adapters, such as those on Amazon. Basically UP and LEFT on the joystick are not recognized during the Input config process.

    This affects a lot of people and so has been solved at a href=”

    Could you kindly compile the fix into the next update?





    Aside from the spam post above, wanted to bump the OP since if this could be built into RetroPie I think it would be a HUGE help in getting everything working easily.



    Same here, I am using the Innex USB converter to connect two Suzo Arcade joysticks. I have tested this with 2.3 and 3.0b1. Same symptoms, and can be solved like this:

    Can you consider using this in the retropie distro?



    Tested with 3.1 and issue still exists. This makes Retropie useless to me as a replacement for PC-based Amiga and C64 emulators.

    Could you please compile this fix in a next update?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss