Atari 2600 / Emulation Station 3.0 / Stella

Home Forums RetroPie Project Controller Configuration in RetroPie Atari 2600 / Emulation Station 3.0 / Stella

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of aztockdog aztockdog 1 year, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #105511
    Profile photo of ronearp
    ronearp
    Participant

    I’m running Emulationstation 3.0 beta that uses Stella for Atari 2600 emulation. I’m using a generic Xbox game pad controller for input. The 2600 games work fine with the D-pad controller and “b” button mapped as the moving and firing respectively.

    BUT – I can’t leave 2600 games. The only way I have to get out of a running 2600 game is to pull power on the RPi.

    I have a Bluetooth keyboard attached and NO key on the keyboard will exit an Atari game, or, take me to a configuration menu for Stella keys. Esc, tab, that should work do nothing. And I don’t have a button on the controller to exit. I suspect I’ve buggered up the mapping somehow when I mapped it a couple of weeks ago, but, I re-imaged the SD card with a fresh ES 3.0 beta to no avail.

    Is there a key combination that will exit the emulator? Or take me to the menu?

    Or, do I need to edit a file on the system to remap the keys? Any help would be appreciated but I’m quite inept with UNIX so even simple file editing is a challenge for me.

    Thanks much,
    Ron

    #105521
    Profile photo of herbfargus
    herbfargus
    Member

    Have you tried Ctrl+q? The default emulator I believe is lr-stella which uses retroarch configs so default hotkeys to exit are select+start. See this page:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Atari-2600

    #105524
    Profile photo of ronearp
    ronearp
    Participant

    I just tried Ctrl-q to no avail. I know my keyboard works as the tab, esc, etc. keys work fine under MAME. I also tried SELECT+START which are mapped to two keys on my controller.

    Any other ideas? I think if someone can guide or explain where the key mapping file is for Stella I could maybe edit that file and get escape and tab enabled again. Escape is supposed to leave the game and tab would take you to the Stella control menu.

    #105735
    Profile photo of ronearp
    ronearp
    Participant

    Back up again – any other ideas for getting into Stella’s control screen while an Atari 2600 game is running? Back door or special key combo?

    I’ve been completely unsuccessful.

    Thanks,
    Ron

    #105786
    Profile photo of ezdude
    ezdude
    Participant

    Hello there. I had the exact same problem.

    I found that if you press the “start” and “back” button simultaneously it will stop the game and take you back to Emulation Station.

    Hope this helps.

    On a side note, I found the “F1” key takes you out of Intellivision takes out of that emulator. That one took me awhile.

    #105787
    Profile photo of ronearp
    ronearp
    Participant

    Start and back on the XBox controller? I’ll definitely try that, but, I think that will depend on what the Start and Back buttons from the Xobx controller are mapped to in Stella.

    I really need to figure out a way to get to the Stella keymapping file or application.

    #105987
    Profile photo of aztockdog
    aztockdog
    Participant

    Hi all!

    I am also looking for this same info and also how to actually configure the video settings (like on the Windows version of Stella) where you can select the refresh (PAL vs NTSC etc), scanline options etc

    But, for now just being able to exit back to the main EmulationStation screen will be a bonus!

    Cheers 🙂

    (This is my first post to the forum so a big hello to everyone and I will post an introduction soon- if there is thread of that nature)

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar