Arcade Joystick and buttons used on I/O pins

Home Forums RetroPie Project Everything else related to the RetroPie Project Arcade Joystick and buttons used on I/O pins

This topic contains 1 reply, has 0 voices, and was last updated by  Gerdi 2 years, 12 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #9508

    Gerdi

    Hello,

    I build my on arcade with Retropie version 1.10. So I used 6 Buttons (http://www.arcadeshop.de/ILSA-Buttons-Pushbutton-SL-gelb_557.html) and a joystick (http://www.arcadeshop.de/Seimitsu-Joysticks-LS-32-Seimitsu_667.html). I connected them directly to the I/O pins (GPIO) of Raspberry. I used the retrogame software from adafruit (https://learn.adafruit.com/retro-gaming-with-raspberry-pi/buttons) to map the I/Os. This is working and for example Button 1 is know emulated as “Y” on the keyboard.
    I tried to config doom and so on with the arcade controls and it works, but then I tried to use the arcade controls for MAME without access.
    I tried to configure the controls at the Input Configuration site. This one works and raspberry recordnized my buttons and the joystick. Then I tried on the Input Configuration site to open RGUI. Here I tried to configure also the controls. But when I try to change for example Button A the software didn’t recordnize my arcade controls on I/O port. This problem is only on th RGUI config. All other configs are recordnizing my controls.
    Can somenbody help me?
    Thanks

    #9710

    Gerdi

    For better understanding. My Retroarch does nor recordnize my keyboard. If I go into the Input config and try to change a button, for example from key “X” to key “B”, the Retroarch does not recordnize my key input. Only the ESC button is working in this config.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar