Arcade build – problem using a Dell E193FP monitor with a Pi 2B

Welcome Page Forums RetroPie Project Video Output on RetroPie Arcade build – problem using a Dell E193FP monitor with a Pi 2B

This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of ericb ericb 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #108115
    Profile photo of ericb
    ericb
    Participant

    Hi,

    I’m building a bartop Arcade machine using a RaspBerry Pi 2B and RetroPie 3.1 to power it. I have an old Dell E193FP which works fine and fits perfectly in the case. However, I’m having a problem with them to display correctly.

    The E193FP has a VGA connection so I’m using an adapter – this one: https://www.kabeldirect.nl/hdmi-naar-vga-adapter.html?sqr=GE/A-HDMI-VGA-001& – to connect it to the Pi 2B HDMI connector. When I power up the Pi with the E193FP, the screen stays blank. When I power up the Pi with an HDMI iiyama screen, then disconnect the HDMI cable and connect the E193FP with the adapter, the display works fine. Although too wide, probably because the E193FP has an aspect ratio of 4:3 vs 16:9 of the iiyama.
    Obviously, it’s no option to (dis)connect the iiyama and Dell everytime for the intended use as bartop Arcade machine.

    Maybe there are some settings I have to change to get it working fine? Maybe the problem is the HDMI-VGA adapter? Although it works fine after the manual iiyama / Dell swap.

    Any help would be very welcome!

    Eric

    #108150
    Profile photo of ericb
    ericb
    Participant

    OK, I found the solution for my problem – should have searched a bit better yesterday 😉

    I found this link: http://weblogs.asp.net/bleroy/getting-your-raspberry-pi-to-output-the-right-resolution

    I had to set the video settings of the Pi to the Dell’s native settings, 1280 x 1024 @ 75 Hz in my case, and the problem was solved.
    BTW: I just had to add sudo to the nano command.

    Eric

    #108273
    Profile photo of ericb
    ericb
    Participant

    Update: unfortunately, yesterday the problem appeared again.
    I enabled the ‘hdmi_safe=1’ option in config.txt and it seems to keep working good now.
    More info about configuring the Pi are over here: http://elinux.org/RPiconfig

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar