Anyone else having problems connecting to Wifi with Cana Kit USB Wifi Adapter?

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Anyone else having problems connecting to Wifi with Cana Kit USB Wifi Adapter?

This topic contains 5 replies, has 3 voices, and was last updated by  HoustoneD 2 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #109484

    HoustoneD
    Participant

    I can see networks and have tried various methods of connecting to various wifi networks.

    I have a Raspberry Pi 2, running RetroPie 3.2.1 in a BerryBoot Multi boot (alongside OpenELEC and Kali)

    I have tried editing the wpa_supplicant.conf file and also using the wizard in the RP setup script. What could i be doing wrong? I can connect fine in my other OSes.

    Please help. I cannot seem to find anyone else having this issue.

    #109572

    HoustoneD
    Participant

    I scratched the plan of using berryboot. I installed 3.2.1 from scratch, updated the setup script, and connected to wifi with no issues.

    Rather than use a multi boot setup, i will run kodi from within retro pie’s gui. I can live without kali on my media/gaming center.

    #110076

    techytecherson
    Participant

    YES!! I’ve been trying to get mine going for half a month, I know a little about linux, and I’ve tried EVERYTHING! every thing i can find on youtube and forums, but nothing seams to work, i can see it, i can write files to the pi over the network, but can’t get it to connect onto the internet only my home network, and therefor i can’t get apt-get update to work or anything, I really need to get on the net so i can get this thing working, I’ve also tried both wired and the CANA usb wifi, i know the adaptor works i can see it lsusb and like i said i can write files to the pie but can’t get it to go out to the internet I hope that someone can help me this is driving me crazy!

    #110288

    HoustoneD
    Participant

    Techy- if you are still having problems, I can offer advice.

    I was using berryboot originally so I could have both retropie and openelec.

    I scratched that plan. Do a standard load of retropie 3.2.1, then install Kodi from experimental setup in retropie_setup.sh. I think since berryboots filesystem is flat, we cannot write data to certain files. You could try adding user pi to admin or use chmod777 to see if it is a possible permissions issue.

    I think I’m done with berryboot though. It’s cool, but I think just running kodi out of ES is better

    Sent from my XT1254 using Tapatalk

    #110347

    ronoh55
    Participant

    One other tidbit of info needed. The pi (or maybe it’s the adapter?) doesn’t like WEP encryption. You have to use WPA or WPA2 to get it working. This thread just reminded me I had one of the adapters and solved a problem I was having, but I had to change my encryption to get it working.

    #110353

    HoustoneD
    Participant

    Ronoh- i had actually tried both (my neighbor has a wep that i tested on). If anyone is reading this with WEP, please change to WPA ASAP. Takes about 30 minutes max to hack.

    Also, please disable WPS if you are using WPA or WPA2, this is also very easy to hack.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss