Any tips to squeeze more speed out of AdvanceMAME?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Any tips to squeeze more speed out of AdvanceMAME?

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of tpr70 tpr70 1 year, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #114210
    Profile photo of tpr70
    tpr70
    Participant

    I’ve noticed several games in AdvanceMAME seem to slow down a bit or the audio gets out of sync. I’ve tried overclocking the Pi and that doesn’t seem to do much. Any tips or tricks anyone might have tried in the config to squeeze a bit more speed out of the emulator or get the sound working better?

    Thanks for your help!

    #114241
    Profile photo of dudleydes
    dudleydes
    Participant

    I had similar sound problems with Bubble Symphony and Elevator Action Returns using AdvMAME 1.2 and 1.4. Both run fine in AdvMAME 0.94 on my rpi2 with default overclocking.

    #114247
    Profile photo of dankcushions
    dankcushions
    Participant

    yeah, don’t use advancemame 🙂

    but really, mame4all-pi is a great one for raw speed, and mame2003 is pretty much the same performance, supports a huge library, and has the benefit of being a libretro core (so uses all the automatic controller configuration, etc).

    #114258
    Profile photo of tpr70
    tpr70
    Participant

    Actually, I think I found a solution that has worked in about 99% of the games I was having trouble with.

    In the advmame-1.4.rc settings there was this option:

    display_vsync yes

    and I changed it to:

    display_vsync no

    That seems to clear up a lot of the sound issues without distorting anything else.

    #114266
    Profile photo of petrockblog
    petrockblog
    Keymaster

    had you enabled this yourself ?

    our default setting is to have this off

    #114267
    Profile photo of tpr70
    tpr70
    Participant

    The initial setup I had was done by someone else so it’s very possible they enabled it and I didn’t notice. But I’m glad I figured it out because it’s working MUCH better now!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar