Amiga Emulator

Tagged: 

This topic contains 15 replies, has 7 voices, and was last updated by Profile photo of trixster trixster 2 years, 1 month ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #31060
    Profile photo of radamanthine
    radamanthine
    Participant

    Hi all,

    Has anybody managed to get this to work? Scraper and all?

    After install I copied my kick.rom to:

    /opt/retropie/emulators/uae4rpi

    and some roms to:

    /home/pi/RetroPie/roms/amiga
    
    

    … in their own folders.

    First thing I came up against was a permissions issue for “pi” user for the location of the emulator which I solved with the aid of a search engine with:

    sudo chown -R pi /opt/retropie/emulators/
    sudo chgrp -R pi /opt/retropie/emulators/

    … I don’t know if this is the best way of doing it I am a bit of a Linux novice.

    I then tried to run the scaped roms from the menu with no luck. I also tried to create a symbolic link with the code:

    ln -s /home/pi/RetroPie/roms/amiga/Silkworm/SILKWORM.adf df0.adf

    … this just added another entry to the scraped rom for df0 but activating either that or SILKWORM.adf just left me with the workbench 1.3 screen and no disk loading.

    … any help would be appreciated, even if it is to slap me for a noobish mistake.

    Many thanks.

    #31591
    Profile photo of coned
    coned
    Participant

    I canon not copy the kick.rom to /opt/retropie/emulators/uae4rpi

    The permission is missing! How can i set the permission for this folder.
    I can’t change the rights that i can copy it to the folder!

    #31797
    Profile photo of radamanthine
    radamanthine
    Participant

    I ended up connecting to the Pi via the network with WinSCP logging in as root with a password of raspberry

    You will need to boot the Pi and then press F4 to exit emulation station.

    When back in the terminal you will need to run ifconfig to find the Pi’s IP address assuming you are connected to your home network.

    Once the kick.rom is in I then changed the permissions of the whole emulators folder to allow the pi login access with the following lines:

    sudo chown -R pi /opt/retropie/emulators/
    sudo chgrp -R pi /opt/retropie/emulators/

    … at least I think that’s what those lines are doing. Somebody a bit more versed in Linux will be able to tell you for sure.

    Unfortunately I am still a novice and only getting about half an hour a night to play around with this.

    Hope that helps.

    #31818
    Profile photo of radamanthine
    radamanthine
    Participant

    Yes!!!! Okay so I have had a little success. It appears that the issue is down to the /opt/retropie/emulators/uae4rpi/startAmigaDisk.sh not creating the df0.adf correctly.

    If you first navigate to the emula/tor directory using:
    cd /opt/retropie/emulators/uae4rpi

    … then when in the directory create the symbolic link so it is in the correct location with:
    ln -s /home/pi/RetroPie/roms/amiga/<your .ADF> df0.adf

    … this creates a symbolic link to the .adf called df0.adf in the emulators directory where the emulator is looking for it!

    You can then run the emulator with the command:
    ./uae4all

    PHEW! Right so next up is to figure out why that script isn’t working. As it is it is creating the symbolic link to the rom directory and not to a specific file.

    I realise this might not be news to some but I figured it might help if I document as I go from my complete noob prospective.

    … that’s it for tonight!

    #32616
    Profile photo of radamanthine
    radamanthine
    Participant

    SUCCESS!!!!

    After playing with the startAmigaDisk.sh file to see what arguments are being passed to it I figured that the .adf file is actually being passed to the script, just isn’t being used.

    Change the /opt/retropie/emulators/uae4rpi/startAmigaDisk.sh file to look like this:

    
    #!/bin/bash
    pushd "/opt/retropie/emulators/uae4rpi/"
    rm df0.adf
    ln -s $1 "df0.adf"
    ./uae4all    
    popd

    The only change is to replace the path to the roms folder with $1 which is the full path to the .ADF file that you executed from the user interface that is being passed in as the first (and only) argument.

    The emulator should now run from the user interface directly. However this will only work for a game with one .adf file.

    Next challenge to get it working for games with multiple disks.

    This is great… I am learning lots! Its like how I began figuring out PCs… trying to create boot disks to get DOS games to work! 🙂

    #38231

    Hendrik

    Thank you so much. It totally worked for me too. The amiga emulation is pretty slow though… 🙁 Any idea how to bind the joy buttons to the keyboard? I didn’t got it working through these switches.. -s joyport0=keyb1 bla bla

    #91697
    Profile photo of minos
    minos
    Participant

    Hello, need a little help in here, i dont have the startAmigaDisk.sh on uae4rpi folder, how do i create it?

    Sorry for noobing…
    Pedro

    #91700
    Profile photo of petrockblog
    petrockblog
    Keymaster

    with the latest retropie this is no longer used – it boots directly into a gui.

    #91829
    Profile photo of minos
    minos
    Participant

    Thanks Buzz, i’m sure i have the latest, but in emulation station when i navigate to amiga emulator page and choose a game it tries to load and retrive a black screen and return to emulation station. Can help me here?

    * I had put the rom files (i’m using as ‘kick.rom’ file the kick1.3 512kb rom) in pi/RetroPie/emulators/uae4rpi folder;
    * Then put the games .adf files in pi/RetroPie/roms/amiga;
    * Had added the entry of amiga emulator on es_config file, to have an amiga emulator page on emulation station:

    DESCNAME=Amiga
    NAME=amiga
    PATH=/home/pi/RetroPie/roms/amiga
    EXTENSION=.adf .ADF
    COMMAND=/home/pi/RetroPie/emulators/uae4rpi/uae4rpi.sh %ROM%
    PLATFORMID=4911

    * Created the script at /home/pi/Retropie/emulators/uae4rpi/uae4rpi.sh with following content:

    #!/bin/bash
    UAEPATH=/home/pi/RetroPie/emulators/uae4rpi
    rm -fr $UAEPATH/df*.adf
    case $1 in
    *_disk1.adf|*_disk1.ADF)
    ln -s $1 $UAEPATH/df0.adf
    ln -s ${1:0:-5}2.adf $UAEPATH/df1.adf
    ;;
    *_disk2.adf|*_disk2.ADF)
    ln -s $1 $UAEPATH/df1.adf
    ln -s ${1:0:-5}1.adf $UAEPATH/df0.adf
    ;;
    *)
    ln -s $1 $UAEPATH/df0.adf
    ;;
    esac
    cd $UAEPATH
    ./uae4all

    (did a “chmod +x uae4rpi.sh” to mark it as executable)

    So if i try to run any amiga game from Emulation station it goes to terminal and apear the message:

    sh: 1: /home/pi/RetroPie/emulators/uae4rpi/uae4rpi.sh: not found

    and returs rapidly to emulation station

    If i try to run uae from the terminal with:

    ./uae4all

    it takes me to a black screen freezing the pi, must plug of to rebbot.

    Please help me here…
    Thanks in advance,
    Pedro

    #91850
    Profile photo of petrockblog
    petrockblog
    Keymaster

    could you stick to replying on a single thread please – to avoid confusing things.

    First of all I assume you are running retropie 2.6 image. You should at least start with that.

    some points:

    You can’t launch games directly from emulationstation. It doesn’t support that. You launch the emulator and go from there. Don’t edit the emulationstation config. Don’t add any additional script.

    kickstarts go to the ~/RetroPie/BIOS folder (called kick13.rom kick20.rom etc). The emulator ships with a working AROS kickstart replacement though.

    to run it directly from console (if you really want to), and without using runcommand, you will need to switch the SDL driver to use dispmanx

    SDL1_VIDEODRIVER=”dispmanx” ./uae4all

    #91857
    Profile photo of minos
    minos
    Participant

    First of all, thanks for the fast reply, i’m very sorry for double replying on different threads. Ok,i deleted the kickstarts from ~/RetroPie/emulators/uae4rpi folder and put them in ~/RetroPie/BIOS folder, i have there:

    kick13.rom (512kb)
    kick20.rom
    kick30.rom
    kick31.rom

    Restored the emulationstation config to previous configuration (removed the amiga entry)

    then opened the terminal and SDL1_VIDEODRIVER=”dispmanx” then when i launch the ./uae4all it appears a black screen with 2 rectangles (green and red) at the bottom right then comes back rapidly to terminal…

    No luck around here…

    #91860
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you are not running the latest uae4all. No idea what image you are running, but it is older than the 2.6 I mentioned.

    Without knowing how old your image is, you might do better to start with a retropie 2.6 image, or alternatively backup your configs, update retropie-setuph and do a full binary install.

    #96998
    Profile photo of methanoid
    methanoid
    Participant
    #97003
    Profile photo of trixster
    trixster
    Participant

    RetroPie uses none of those versions.

    #97004
    Profile photo of methanoid
    methanoid
    Participant

    Actually found a 3rd version at Pi forums.. Why does RPie use the oldest of all of them then? I would assume that new releases offer something extra???

    #97005
    Profile photo of trixster
    trixster
    Participant

    I believe RetroPie uses this version:

    https://github.com/joolswills/uae4all2

    I personally think the Chips version is currently the best:

    https://github.com/Chips-fr/uae4all2
    https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=102328

    You can easily integrate this version into RetroPie with a little bit of work.

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar