Advanced Launcher plugin usage under Xbian

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Advanced Launcher plugin usage under Xbian

This topic contains 1 reply, has 1 voice, and was last updated by  calcon79 3 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #5363


    Ok so first I will admit that I am a Linux noob so I am pretty much tinkering with this setup but I have managed to get something working using the Advanced Launcher plugin. So far I can launch xbian-config and LXDE and automatically return to XBMC after closing these programs. I found two files named and from the following forum.

    The last post yielded the settings that worked for me. I made a minor tweak to the file so I have provided the files on here.

    Despite successfully launching these programs from XBMC, I cannot for the life of me get it to work with emulationstation. The scripts use a screen command to keep a terminal session alive after stopping xbmc. Otherwise the original script will terminate along with the stop xbmc command. As far as I can tell the openvt command opens a virtual terminal session as root. It seems emulationstation will not run as root. I’ve tried many different things. It seems I cannot force the command passed to openvt to be run as user “xbian”. Does anyone have any ideas for how to get emulationstation to run in a shell script that is being run under a root user?

    My last resort option was to try and create a script which might incorporate the following to force emulation-station to start on a reboot

    sudo update-rc.d xbmc remove
    sudo update-rc.d emulation-station default

    Of course I’m not sure how to do the second command either since in my setup I may not have the emulation-station service. I installed RetroPie under my Xbian 1.0RC1 OS. So I have to manually start it by logging off XBMC and entering the command /home/xbian/RetroPie/supplementary/EmulationStation/emulationstation. Which works quite nicely except I have to login and enter the command which gets annoying. I would prefer an easier approach like launching it from XBMC.

    From within emulationstation, I would need to add a application script witch will of course do the opposite.

    sudo update-rc.d emulation-station remove
    sudo update-rc.d xbmc default

    If anyone has any ideas, I would appreciate this. It seems not many people even have a working advanced launcher setup with Xbian so I have at least made good progress with that so far. I just need to make this work with emulationstation.



    Ok I apologize for the confusion with attachments. I had to change the extensions to .txt and I realized I uploaded a with something commented out. I am reattaching the correct files here. If someone knows how I can remove the original file attachments please let me know.

    I also added my launcher.txt file so you can see the three launchers I have created. The only one that doesn’t work is the one for emulation station.

    Update: Since I can’t figure out how to remove an attached file. I’m not going to reupload another one. I noticed my still had a line commented out. I commented out the restart xbmc command. Normally this is not commented out but I was trying to freeze the script to figure out what was going on. Also these files are named,, and launchers.xml.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss