A Couple of Questions for Running Neo Geo on PiFBA

Home Forums RetroPie Project Everything else related to the RetroPie Project A Couple of Questions for Running Neo Geo on PiFBA

This topic contains 11 replies, has 5 voices, and was last updated by Profile photo of typh0id typh0id 3 years ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #7065
    Profile photo of typh0id
    typh0id
    Participant

    PiFBA is working great for me for the most part…the CPS1 and CPS2 games run flawlessly and Neo Geo games generally run well but I’m having a couple of specific issues I can’t seem to figure out:

    1) I can enter the Service Menu for the Capcom games but when I press the same combinations of buttons in a Neo Geo game I just get a black screen.

    2) Several of the Neo Geo games don’t have sound. I know that these games are encrypted but I’ve read several places that you can add the files from the decrypted sets to the encrypted ones to fix that. For each game with no sound I’ve added the files from the set ending in “nd” (eg. I too the files from SVCND.ZIP and added them to the SVC.ZIP file) but this makes no difference. I’ve tried doing the reverse of that as well (eg. adding the files from SVC.ZIP to SVCND.ZIP) but that also has no effect. Using SVC as an example, the combined file contents look like this:

    269-c1r.bin
    269-c2r.bin
    269-c3r.bin
    269-c4r.bin
    269-c5r.bin
    269-c6r.bin
    269-c7r.bin
    269-c8r.bin
    269-m1.bin
    269-p1.bin
    269-p2.bin
    269-v1.bin
    269-v2.bin
    svcn_c1.rom
    svcn_c2.rom
    svcn_c3.rom
    svcn_c4.rom
    svcn_c5.rom
    svcn_c6.rom
    svcn_c7.rom
    svcn_c8.rom

    Does anyone have any advice for these two issues? Also, this is likely a stupid question but is there anyway to have the full game names display in EmulationStation? I tried renaming the .zip files (eg. lastblad.zip to Last Blade.zip) but that just stopped the game from working as I figured it would.

    Thanks in advance!

    #7066
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Forum member Cacophony555 created a script to generate a gamelist with full game titles from MAME/FBA rom filenames, see here: http://www.raspberrypi.org/forums/viewtopic.php?f=78&t=70957

    If you have found the solution to your problem please mark the topic as resolved.

    #7067
    Profile photo of petrockblog
    petrockblog
    Keymaster

    If you think that the script of Cacophony555 would be a valuable addition to the RetroPie-Setup Script it would be great if you could post a corresponding bash function with it or even a pull request at Github.

    #7124
    Profile photo of nemo93
    nemo93
    Participant

    Hey typh0id,

    if you can’t access the service menu it indicates that you’re using the wrong neogeo bios file (neogeo.zip). I was in the same situation but since I’ve found a fairly smaller bios file (with less files within) I can successfully access the service menu by pressing SELECT+LT+RT on my Xbox controller under piFBA and turn on the blood in all mslugs 🙂

    Regarding sound and some Neo Geo games well it also means that you’re using the wrong rom files or as trimmtrabb said you need the “decrypted” M1 file to be present within those roms (for SVC it should be 269-m1_decrypted.bin). If you Google a bit I’m sure you’ll find a good place to get these. Also have a look at the output.log file located in the /home/pi/RetroPie/emulators/pifba/ directory.

    After testing all Neo Geo games I can confirm that only 4 don’t work properly with piFBA:
    * mslug3 (crash on launch)
    * kof2000 (crash on launch)
    * ridhero (launch but crash w black screen as soon as the race starts / works ok on mame4all)
    * zedblade (glitches/messy background / works perfect on mame4all)

    Finally with respect to your last question, the script from Cacophony555 helps a lot to build a gamelist.xml file allowing you to specify a name for your roms. It’s still manual though but better than nothing! As a bonus if you have images/boxarts for your games they’ll be picked up automatically (you have to use same name rom file/image). Let me enclose my own file here, simply rename it to gamelist.xml and put it into your neogeo or fba roms dir and you’re done!

    hope this helps!
    cheers,

    #7162
    Profile photo of typh0id
    typh0id
    Participant

    First off, thanks for all the advice. It has been very helpful!

    nemo93: Taking your suggestion I found a different neogeo.zip bios and sure enough I can now access te service menu.

    I will look for those decrypted ROM files you mentioned.

    As for the gamelist.xml, however…I did generate one and put it in my roms folder and as far as displaying the full game names, it worked…The problem is that it overrides my existing theme.xml for that menu and now I just have a white screen with the game names all on the righthand side (I had them centered without boxart etc)…Is there anyway to incorporate the gamelist into my current theme?

    #7173
    Profile photo of nemo93
    nemo93
    Participant

    hi there,

    problem is not with the gamelist.xml itself but with the theme.xml file. In this file you have two main tags: <theme> and <basictheme>. The former is the theme that will be used in case a gamelist.xml is present in the “roms” folder. The latter is used when there is no gamelist.xml file.

    Hence make sure that your <theme> section is declared properly and used existing objects like background files etc.

    hope this helps!
    cheers,

    #7220
    Profile photo of typh0id
    typh0id
    Participant

    Oh man…I am ALMOST there…I took your advice swapped the “theme” and “basicTheme” setups and my background and header and font, etc. all now show up…But I can’t seem to get the list of games back to the center of the screen. They are pushed way over to the right side, I guess to make room for boxart. But I don’t care to use boxart. Can you use gamelist.xml but not use boxart and keep the text list in the center of the screen?

    Also, one more question about the service menu…PiFBA doesnt seem to save any of my dipswitch settings…Is there a way to fix that or is that just how it is

    #7235
    Profile photo of kitchuk
    kitchuk
    Participant

    First off, thanks for all the advice. It has been very helpful!

    nemo93: Taking your suggestion I found a different neogeo.zip bios and sure enough I can now access te service menu.

    I will look for those decrypted ROM files you mentioned.

    As for the gamelist.xml, however…I did generate one and put it in my roms folder and as far as displaying the full game names, it worked…The problem is that it overrides my existing theme.xml for that menu and now I just have a white screen with the game names all on the righthand side (I had them centered without boxart etc)…Is there anyway to incorporate the gamelist into my current theme?

    I’m also having trouble with the neogeo.zip and the service menu. Could you possibly post a link (private message) to the correct bios?

    #7236
    Profile photo of kitchuk
    kitchuk
    Participant

    Hey typh0id,

    if you can’t access the service menu it indicates that you’re using the wrong neogeo bios file (neogeo.zip). I was in the same situation but since I’ve found a fairly smaller bios file (with less files within) I can successfully access the service menu by pressing SELECT+LT+RT on my Xbox controller under piFBA and turn on the blood in all mslugs :)

    Regarding sound and some Neo Geo games well it also means that you’re using the wrong rom files or as trimmtrabb said you need the “decrypted” M1 file to be present within those roms (for SVC it should be 269-m1_decrypted.bin). If you Google a bit I’m sure you’ll find a good place to get these. Also have a look at the output.log file located in the /home/pi/RetroPie/emulators/pifba/ directory.

    After testing all Neo Geo games I can confirm that only 4 don’t work properly with piFBA:<br>
    * mslug3 (crash on launch)<br>
    * kof2000 (crash on launch)<br>
    * ridhero (launch but crash w black screen as soon as the race starts / works ok on mame4all)<br>
    * zedblade (glitches/messy background / works perfect on mame4all)

    Finally with respect to your last question, the script from Cacophony555 helps a lot to build a gamelist.xml file allowing you to specify a name for your roms. It’s still manual though but better than nothing! As a bonus if you have images/boxarts for your games they’ll be picked up automatically (you have to use same name rom file/image). Let me enclose my own file here, simply rename it to gamelist.xml and put it into your neogeo or fba roms dir and you’re done!

    hope this helps!<br>

    cheers,

    Did you also find that the music in Art of Fighting 3 is horrible/garbled?

    #7242
    Profile photo of typh0id
    typh0id
    Participant

    I’m also having trouble with the neogeo.zip and the service menu. Could you possibly post a link (private message) to the correct bios?

    I don’t actually recall where I got my working neogeo.zip but I just googled it and checked various sites until I found one that was about 240KB in file size (My previous one had been about 1.2MB)

    After testing all Neo Geo games I can confirm that only 4 don’t work properly with piFBA:
    * mslug3 (crash on launch)
    * kof2000 (crash on launch)

    Actually I found that if you add the contents of mslug3.zip to the mslug3n.zip and then run mslug3n.zip in piFBA, it works perfectly! The same method also works for KOF2000 (again, just make sure once you’ve combined kof2000 with kof2000n that you leave the file named kof2000n.zip).

    So nothing I’ve tried has fixed my issues with using gamelist.xml and still maintain the centered list…I read something that implied that basic mode puts the list in the center but regular mode (when using gamelist.xml) is designed to use frames for boxart and such…Is this true? It seems like the xml could be edited to get around that but I can’t seem to figure out what’s causing it to begin with.

    And I know for MAME you have to create a cfg folder in the emulator’s directory…Is there a similar folder you need to create for PiFBA to get the dipswitch settings to save?

    #7364
    Profile photo of nemo93
    nemo93
    Participant

    Hi typh0id,

    thanks for the tip!

    Actually I found that if you add the contents of mslug3.zip to the mslug3n.zip and then run mslug3n.zip in piFBA, it works perfectly!

    Actually this works indeed nicely 🙂

    With respect to your themes related question I trust this has something to do with the <listLeftAlign /> tag. If it’s present in your <theme> just remove it or comment it out that should do the trick. Always refer to the THEMES.MD documentation from Aloshi to find more informations.

    I have no clue if it’s possible to save dipswitch from piFBA. I can’t help on that one I’m afraid.

    cheers,

    #7391
    Profile photo of typh0id
    typh0id
    Participant

    I tried removing the <listLeftAlign> tag and the result was the list being pushed even FURTHER over to where I could barely see it. I also tried renaming it <listCenterAlign> which didn’t help either.

    I saw something online though, I believe it was on the website forum for EmulationStation, saying that in the next version that issue will be addressed and if you don’t have any boxart images present gamelist will default to basictheme. I guess I’ll just have to wait this one out. Thanks again for the advice though!

Viewing 12 posts - 1 through 12 (of 12 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar