8Bitdo30 Bluetooth SNES Conrtoller: Issues

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 8Bitdo30 Bluetooth SNES Conrtoller: Issues


This topic contains 4 replies, has 2 voices, and was last updated by  xsomeloser 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #107369


    Hello, I am new to Retropie and Raspberry Pi.
    I have been using this website for pretty much everything and it is awesome.

    Ok, now the issue.
    I once successfully followed “Floob’s” tutorial on how to trust, connect, and configure the controller and it worked great! For awhile.. Now the controller will not connect to my Pi. When trying to connect I get the error, Invalid Exchange (52). I have double checked to see that everything is setup the same. And I even uninstalled/removed it and followed the tutorial a second time with no luck.

    If I posted this in the wrong place, please direct me to where I should be posting. I am a total n00b, here to learn and play with my new Pi.





    I made a couple of tweaks on the guide after I did the video – does this help?

    Ideally you would start clean, but it should be ok. You should be able to remove the existing paring like this
    bluez-test-device remove XX:XX:XX:XX:XX:XX

    I *think* the error you have implies that you are trying to connect without pairing first. Try following the guide and let me know the first step that doesnt behave as expected.

    Or you could try the PiAssist by Death259 script which deals with Bluetooth, this is part of RetroPie now – and can be found in the retropie setup script.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl



    @ Floob,

    Thank you for the quick reply.

    The tutorial that you have shared is the same that I have followed. I have removed the device and then trusted/paired it again, but when it tries to connect I still get the Invalid Exchange (52) error. I even tried this one more time after your reply.

    Also, I have installed Raspbian Jessie on another SD card. I have tried to pair bluetooth on that as well, but get an error when trying to run, ‘sudo apt-get install bluetooth bluez-utils blueman’

    The output is:
    Package bluez-utils is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or is only available from another source
    However the following packages replace it:
    E:Package ‘bluez-utils’ has no installation candidate

    When I did install, sudo apt-get install blutooth bluez blueman, commands like, sudo bluez-simple-agent hci0 XX:XX:XX:XX:XX:XX, are not found.

    I realize I am just ranting off a bunch of random stuff now but I am just wondering, is there new syntax with “Jessie”
    I was just trying to do the same thing as before and get my controller and retropie working with a fresh new build thinking “Jessie” may resolve the issue, but got stuck there.

    I have not tried the PiAssist by Death259 yet, I will let you know if that works.




    🙂 Just now saw the reply button. I simply added to the thread rather than hitting reply. Just now using reply so that you see latest post.






    I finally got a chance to try PiAssist by Death259 and it worked like a charm.
    I am not sure why I was not able to get it to work again, when your instrustions worked the first time. But I am glad to finally have it working again. Thank you very much for your suggestion.

    And thanks to Death259 for the great tool!


Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss