8bitdo Controller didn't connect on boot (RPI3)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 8bitdo Controller didn't connect on boot (RPI3)

This topic contains 5 replies, has 4 voices, and was last updated by  mustbaj 1 year, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #119847

    thak
    Participant

    Hi!

    I’ve just received my RPi3 and in order to try more and more game/emulator i tried to install my 8Bitdo NES30 Pro controller with the Bluetooth wiki but no luck!

    I can pair my controller, and even configure it, but if restart the whole system i need to do everything from start again…

    My controller works perfectly with my other RPi2 and retropie (but the 3.3 version)

    It seems that the bluetooth doesn’t start at all on boot.

    Any idea?

    Thanks a lot!

    #119896

    auswear
    Participant

    I had the same issue but doing the following fixed it for me:

    sudo apt-get install pi-bluetooth

    #119897

    thak
    Participant

    I already tried this on a fresh install and it didn’t work 🙁

    #120150

    mustbaj
    Participant

    I can’t get mine to connect on boot either.

    #122229

    Floob
    Member

    I’ve done this to connect on boot. I’ll update it when I find an easier way.

    Wiki: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #122351

    mustbaj
    Participant

    I figured everything out and wrote a How-To

    How To Setup 8bitdo NES30 & FC30 Pro Controllers On a Pi3 with 3.6 from RetroPie

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/