8bitdo Controller didn't connect on boot (RPI3)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 8bitdo Controller didn't connect on boot (RPI3)

This topic contains 5 replies, has 4 voices, and was last updated by  mustbaj 2 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #119847



    I’ve just received my RPi3 and in order to try more and more game/emulator i tried to install my 8Bitdo NES30 Pro controller with the Bluetooth wiki but no luck!

    I can pair my controller, and even configure it, but if restart the whole system i need to do everything from start again…

    My controller works perfectly with my other RPi2 and retropie (but the 3.3 version)

    It seems that the bluetooth doesn’t start at all on boot.

    Any idea?

    Thanks a lot!



    I had the same issue but doing the following fixed it for me:

    sudo apt-get install pi-bluetooth



    I already tried this on a fresh install and it didn’t work 🙁



    I can’t get mine to connect on boot either.



    I’ve done this to connect on boot. I’ll update it when I find an easier way.

    Wiki: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl



    I figured everything out and wrote a How-To

    How To Setup 8bitdo NES30 & FC30 Pro Controllers On a Pi3 with 3.6 from RetroPie

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.