64gb micro SD Wont Boot

This topic contains 6 replies, has 3 voices, and was last updated by  eightbit 2 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #94422


    hello im sing a 64gb micro SD

    when i format it it will format to exfat but when i write the retropie image to it, the green and red LED’s stay on and the pi wont boot

    im pretty sure i need to get it to fat32 somehow but im not sure how it will work

    can anyone please help me out?

    **after using rufus 2.1 to format it to fat32, after writing retropie to the sd card it still wont boot up**



    Might be more helpful if you state what kind of microsd card you are using, which version of retropie you installed, and which model of a Raspberry Pi that you own. And which software you are using to format and write your SD card.

    Check to see if it is a compatible microsd card:

    I use a 64 sandisk ultra and it works fine for me on my raspberry pi 2.

    Also verify you downloaded the right retropie image:
    Raspberry Pi 1= A,A+,B,B+
    Raspberry Pi 2= Raspberry pi 2 model B

    Use SD formatter to format your microsd card.

    Then use win32diskimager to write the SD image to your microsd card. It creates a bootable image which is different than just copying files onto your SD card.

    See this post and the accompanying video for a step by step process.


    It says it is for the 2.6 image but it will also work for the 3.0 image.



    ok i have a raspberry pi 2 model b

    trying to install 3.0 beta 2

    i think the problem is i bought the SD card from ebay and theres no company logo on it which makes me think it’s probably a chinese fake. it also says its class 10

    i’m definatly using the correct image

    i have tried formatting with sd formatter then writing the image with win32 disk imager but it still doesnt boot, my other 8gb sd card worked fine with the beta 2 image



    Yeah eBay is sketch… I got mine off of amazon. I had the same issue with my other 64 GB card I got from a similar site. Its just black and says 64gb and I had the exact same issue that you did… Looks like you got shafted. For your sake I hope I’m wrong.



    yep it’s looking like it to be honest.

    at least i can use the 8gb until i buy a genuine one.

    thanks for the help



    rough go, sorry I couldn’t be of more use- I definitely recommend amazon for sandisk SD cards. I’ve purchased at least 5 cards from them and I’ve never had a problem with any of them. Good luck!



    I use a 64GB Transcend and it works great. Steps I took (I run Ubuntu):

    1. Format to Fat32 using Gparted
    2. Send Retropie image to the card via dd
    3. Insert and boot up
    4. Expand file system

    That was pretty much it. Sounds like you have a crap card. Do not buy these types of things on ebay. Actually, try to avoid ebay for anything you can buy from a reputable online or local retailer 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss