4snes 4nes interface does not work for retropie

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project 4snes 4nes interface does not work for retropie

This topic contains 6 replies, has 3 voices, and was last updated by  koffieleut 2 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #87760

    ehpower2
    Participant

    For those who do not know what i am talking about here is the page about what i am talking about.

    http://www.raphnet-tech.com/products/4nes4snes/

    My issue is after image 2.3 where it worked exactly as it says on the page i have since upgraded to 2.4 images and now 2.5 and the problem is the same.

    When i upgraded to image 2.4 retro-pie refuses to see the rest of the axises and no matter what i only have 2 axies and no matter what port i plug into which 2 of the data lines are for snes ports and the other two are for nes ports it only will see axis 0 and 1 never 2 through 8.

    Also it does not plot the axises accurtely as for instance you can press left hat and all you get as response is 0+ axis.

    I believe this is a bug to how it handles usb but any suggestions and help would be welcome

    #87873

    ehpower2
    Participant

    does anyone have any ideas i really would like to get this working again.

    #88619

    floeggu87
    Participant

    Im having the same problem. in 2.5 / 2.6 there are only two axis recognized.
    i think this could have something to do with the joystick-package. I allready uninstalled and reinstalled/updated it manually. no luck there.

    could there maybe any possibility to install the old version of the joystick package?

    #88678

    ehpower2
    Participant

    I tried to go back to a old kernel and it really does not fix this issue. Is it me or is it seem like the further forward retropie goes version wise the less controllers work. I notice there are much more controller related issues now then there was

    #88799

    floeggu87
    Participant

    I just read an article how to downgrade a package.

    http://askubuntu.com/questions/138284/how-to-downgrade-a-package-via-apt-get

    i’ll try as soon as i get home.

    #89427

    floeggu87
    Participant

    Ive stumbled upon a new post in the forum: http://blog.petrockblock.com/forums/topic/autofire-on-the-axis/

    Some users replied it also fixed their problem with the second controller.
    i’ll test it out this weekend 🙂

    #90404

    koffieleut
    Participant

    It also fixed my problem on 4 player bomberman for pce. So for me it worked perfect.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/