[Solved] 3rd Party/Knock off Xbox 360 Adapter not working

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie [Solved] 3rd Party/Knock off Xbox 360 Adapter not working

This topic contains 0 replies, has 1 voice, and was last updated by  alipoodle 2 years, 6 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #96513

    alipoodle
    Participant

    Running on a raspberry pi 2 b+ (i think) on RetroPi 3.0 Beta 2 Pi 1 (Pi 2 didn’t seem to work for me and others). Link to the Adapter (don’t be fooled by the picture) Amazon Link

    I can’t seem to get my Xbox controller to connect to my Wireless adapter, if i put it in to search mode with a flashing LED as my Pi Boot’s up and my Xbox controller searching for something to connect too. The Wireless Adapt will won’t pick it up and will then turn off searching on the Adapter.

    When i type in “XBOXDRV” this error message show up.
    Controller: Microsoft Xbox 360 Wireless Controller
    Vendor/Product: 045e:0291
    USB Path: 001:004
    Wireless Port: 0
    Controller Type: Xbox360 (wireless)

    — [ ERROR ] ——————————————————
    USBController::USBController(): libusb_open() failed: LIBUSB_ERROR_ACCESS

    I have put in the nessersarry things into sudo nano /etc/rc.local
    in the correct place to what it says on this Topic
    PetRockBlock Forums – Xbox wireless
    I need help connecting it to my Raspberry Pi.

    EDIT
    I have solved the problem by running the XboxDRV as Sudo. and running this when opening EmulationStation,
    Sudo xboxdrv --silent --trigger-as-button --dpad-as-button & emulationstation
    This runs the Xbox DRV to make the triggers and dpad as standard buttons and then run emulationstation.

    Attachments:
Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/