360 controller inputs becomes keyboard input

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 360 controller inputs becomes keyboard input

This topic contains 2 replies, has 2 voices, and was last updated by  demooon 2 years, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #107460


    (skip to problem if you don’t care)
    Okey, setup: I’m running OSMC on a Raspberry Pi 2. And inside the OMSC I’ve got a RetroPie running. At one point everthing was working fine. I could navigate both the OSMC and ES with the 360 controller, and also play games ofc.
    Even had unique controller .cfg for each emulator.

    But at some point the last part stopped working. I can still navigate OSMC and ES with the controller, but when I start a emulator, the controller does not work. I’ve tried every damn “setup you 360 controller” tutorial / option out there. I’ve reinstalled RetroPie. I’ve tried alot of stuff.


    BUT! I think I know what the problem is, but not how to fix it.
    When I run evtest / input registration in ES, the inputs from the 360 controller registers as keyboard buttons. The A button becomes Enter… etc.
    I think this might be the root of my problem, because when it was working the input from the controller was 0-1-2-3 etc.

    Anyone know how to fix this?



    I noticed this happening yesterday. When just the 360 controller is plugged in, everything works fine. As soon as I plug in a keyboard/mouse and reboot, it registers the keyboard as the player 1 joystick and 360 as player 2 joystick (I found this out accidentally when testing on Sonic 2 and Tails starting jumping around instead of Sonic).

    Not sure how to fix yet, but I’m pretty sure there’s a cfg setting somewhere for setting keyboard joystick to on or off… and I think that’s the problem. It get’s parsed before the 360 controller does.



    Well, I don’t have a keyboard plugged into the Pi at all. I never had actually, I do everything through SSH.
    Dunno if the problem is the same… can’t see any sign of it being set to player 2 controlls. Maybe I could plug in a keyboard and see if that is the case. But anywho, we need a solution for the damn thing anyway 😛
    Anyone got the answer for this?

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss