3.6 and PS3 controller not working

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 3.6 and PS3 controller not working

This topic contains 5 replies, has 5 voices, and was last updated by Profile photo of zordrak zordrak 1 year, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #118940
    Profile photo of shoothere
    shoothere
    Participant

    Hi all!

    Got a Pi3 and freshly flashed 3.6 and it boots fine, gets up to the controller config screen, recognizes my usb connected Sony PS3 controller and from there on it doesn’t work.

    It seems it aknowledges the X button but the dpad and analog don’t seem to give any reaction. Up to and including 3.5 it would boot up and be configured very easily.

    Any tips?

    EDIT: forgot to add I tried 2 different controllers.

    #118944
    Profile photo of auswear
    auswear
    Participant

    PS3 controller isn’t working for me on BT either

    #118945
    Profile photo of shoothere
    shoothere
    Participant

    Look in your other post, I linked there to a likely solution to your problem.

    #119374
    Profile photo of gilbertdaemon
    gilbertdaemon
    Participant

    I’m having the same issue (not able to get the PS3 controller to configure on the Emulationstation GUI) but I got it working in a way that I can use it to play games though you still would have to use a keyboard to access the content on the Emulationstation GUI.

    -On the RetroPie Menu
    -Configure RetroArch / Launch RetroArch RGUI
    -Settings
    -Input
    -Input User # Binds

    This way you would be able to play the games but still there is the issue with the PS3 controller not working on the EmulationStation Gui.

    Hope this helps a bit.

    RPi 2
    RetroPie 3.6
    Wired PS3 Controller

    #119389
    Profile photo of gizmo98
    gizmo98
    Participant

    Just run input configuration in emulationstation. PS3 controller has an other device name if it is connected over bt. So it is necessary to add a configuration entry for wireless connections.

    #119502
    Profile photo of zordrak
    zordrak
    Participant

    i can reproduce the same problem with my ps3 controller when using the 3.6 Image (tested on PI2 & 3 and two different original ps3 controllers )
    It works on bluetooth on the pi3 but i doesn’t work using only usb

    On another SD Card i have an upgraded 3.6 Version (using since 2.4 or something) on that one everything works fine.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar