3.0 scraping advMAME

This topic contains 9 replies, has 3 voices, and was last updated by  d8thstar 2 years, 9 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #93822


    I’m just about done with this little box and am trying to scrape with a command line scraper but it keeps bombing out on me. it IS saving the images to the rom folder, image folder, for the games it gets up to, into the letter V.

    but, none of the images are showing when scrolling thru games. i have tried rebooting, i have looked for a location in CFG files, I can’t seem to spot where my error is. all other platforms, including the older mame, have scraped fine and are showing the images.

    thanks again for any help.



    any thoughts? better way for me to ask, what config file does emulationstation use to find the location of snapshots?

    maybe i could edit directly in there.




    Have you scraped with sselphs tool?


    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl



    thanks floob, that is the scraper that i used, i love your videos man, they have been SO helpful.

    curious, i have my mame106 rom on an external drive that mounts when the pi boots up. might that be the issue? emulationstation is looking for images on the sd card but mame games are on the usb hd? i can see in the mame rom folder and image folder and all of the images are in there, they just aren’t displaying in the FE.

    thanks again bud.



    Sorry, I’ve been traveling and not checking the forums. My scraper, by default, places the gamelist.xml and images folder in the directory that you ran the scraper which is the folder with the roms.

    Where/How did you run the scraper and do you have the roms loading from the usb? or is the there some syncing from usb to sd? I’m trying to understand what is listed in the gamelist.xml and if that might differ from where the actual images are. You can check the xml to see what is listed there.

    Auto-scraper: https://github.com/sselph/scraper



    first up, thank you for such an awesome tool.

    i just tried again and am running into the same issue, the scraper is bombing out before it can finish. here is the exact line being output:

    2015/04/12 20:13:18 INFO: Attempting lookup in MAMEDB: viprp1ot.zip
    2015/04/12 20:13:18 ERR: error processing viprp1ot.zip: Get http://www.mamedb.com/game/viprp1ot: dial tcp: lookup http://www.mamedb.com on dial udp too many open files

    the images up to the above mentioned rom have been scraped successfully and are sitting in the images folder. i even opened a couple just to be sure.

    i am running it from within my mame rom directory with the following command:

    ./scraper -mame -thumb_only

    i know that this works as it is the exact command i used to scrape the neo geo titles. i also have used your scraper to scrape just about every other console i have.

    FYI, because it seems to bombing out before it is complete, i can’t seem to find the gamelist.xml file. i see it for my other scraped emu’s, right in the rom directory with the images in a “images” directory within the rom directory.

    also, i have my mame106 rom on an external drive that mounts at boot. this usb hd has a mount point in my /media folder. so my mame rom folder is /media/MAME106/roms wondering if that may be the issue?

    one other bit of info, if i rerun the scraper, it skips the images that it has already downloaded from the previous scrape. taken from the output on a rerun:

    2015/04/12 19:27:22 INFO: Attempting lookup in MAMEDB: dstlku.zip
    2015/04/12 19:27:22 INFO: Skipping images/dstlku-image.jpg
    2015/04/12 19:27:22 INFO: Starting: dstlkur1.zip
    2015/04/12 19:27:22 INFO: Attempting lookup in MAMEDB: dstlkur1.zip
    2015/04/12 19:27:23 INFO: Skipping images/dstlkur1-image.jpg

    so you can see two rom images it looks for and skips, presumably because they are already in the image folder.

    i thank you so much for this GREAT tool and for any insight you may have for me. advMAME106 is the last emulator that I need scraping for (also need playstation but that’s another post).



    Thanks for the detailed info. I think I see the issue, I’ve submitted a fix and pushing a new release. I wasn’t closing the response when the game wasn’t found so after too many of those the error about too many open files happens.

    Auto-scraper: https://github.com/sselph/scraper



    ah cool, thank you very much, can’t wait to try the updated version and report back to you.

    curious when you think i may be able to get my hands on it?

    thank you again.



    It is available here:

    Auto-scraper: https://github.com/sselph/scraper



    just wanted to report back, the scrape was successful! thank you so much for the quick fix!

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss