3.0 – lr-pcsx-rearmed and adafruit-retrogame

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! 3.0 – lr-pcsx-rearmed and adafruit-retrogame

This topic contains 2 replies, has 2 voices, and was last updated by  cosmodk 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #105195


    I hope someone can help me, first my problem…

    playstation 1 emulator lr-pcsx-rearmed is not configured with a default exit keyboard button. How do i do this? as it is now i am not able to exit the game other then turning power off the raspberry pi and boot again.

    I would LOVE if i could get the emulator to exit on press of 1 and 5 on the keyboard (hotkey setup)

    I already tried editing …/all/retroarch.cfg and adding input_exit_emulator = escape but that does not work (i believe that pressing ESC on my keyboard would trigger the emulator to exit, but it does not work 🙁 )

    I am using Raspberry pi2 Model B
    Retropie 3.0 final
    Adafruit-retrogame (for mapping my GPIO arcade controls to keyboard)

    Hope someone can help me out, it seems that everybody is using usb gamepads, there is not much info for us guys trying to build a retro arcade console with microswitch buttons.

    Kind regards
    Jimmy Jensen



    if you configured retropie 3.0 via ES it will have set up the escape button to be “select + start” – which would be whatever keys you mapped it to.

    To change hotkey behaviour from this – use there is a option in retropie-setup / supplementary to change hotkey behaviour – Configure input devices for RetroArch



    i did configure through ES (when it starts ES for the first time) and i set select for key 5 and start for key 1 on my keyboard, however this does not work on exiting games back to ES 🙁 i have tried re-installing from the retropie image 3 times over the last week, but i get the same behaviour.

    i already tried the script to change hotkeys, but that did not help me much unfortunately. Can it be because i am hooked up to the GPIOs? Retroarch does not seem to recognise my input as a “joystick”


Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/