2nd player D-Pad stops working in-game

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 2nd player D-Pad stops working in-game

This topic contains 3 replies, has 2 voices, and was last updated by  armyofmike 2 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #108612

    armyofmike
    Participant

    Hi all,

    I’m trying to get Retropie 3.2 (Pi2) up and running, and having issues with one of my D-pads.

    – Xin Mo USB controller (I have installed feederchain’s kernel)
    – Retropie 3.2 (with suggested retroarch.cfg line removal recommended hours ago)
    – Xin Mo recognized as one controller, all buttons working in jstest, confirmed correct config in retroarch.cfg
    – confirmed correct/solid wiring and grounding to buttons

    In a two-player game, my 1P controls are fine. My 2P buttons are fine except the joystick. It’s strange- a couple of the controls work temporarily, but work backwards (left goes right, up goes down, up goes nowhere). When the game shifts back to 2P for their subsequent turn, the 2P joystick does not work at all. Other buttons continue to work as normal. Again- the mappings I’ve done match jstest. I can recreate this exact scenario every time I boot.

    Has anyone seen this?

    #108613

    petrockblog
    Keymaster
    #108615

    armyofmike
    Participant

    Thanks buzz. I should have mentioned that I’ve attempted this on a previous attempt with no luck. I’ll try it on this install for good measure.

    #108685

    armyofmike
    Participant

    buzz, thank you. I must have had a typo the first time I attempted this. I’m now up and running with 3.2. Apologies for cluttering the forum topics, and thanks to all for the great support here.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/