240p squeeze in emulators

Welcome Page Forums RetroPie Project Video Output on RetroPie 240p squeeze in emulators

This topic contains 13 replies, has 5 voices, and was last updated by Profile photo of quarterturn quarterturn 1 year, 4 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #111307
    Profile photo of r3dstar
    r3dstar
    Participant

    Short version.

    The Retropie splash screen and the games are very narrow, but everything else is fine.

    Narrow screen

    I would say that this is should be another 50% wider.

    Any ideas?

    Forgive the noob questions s I’m about to ask, but we’ve been working on our arcade cabinet over the weekend and we’ve progressed really far considering for the last few years, we were flummoxed by a burnt out fuse.

    We’ve tried two computers, an old PC with an ArcadeVGA card to reduce the signal to 15mhz and it looks awesome, filling the full screen, but the OS WIn XP and we can’t get Emulation Station to work on it, combined with the difficulty of accessing what you want through joystick and buttons without a decent front end.

    THe other solution is my Raspberry Pi 2 with Retropie and we’re so close, but we can only output in 240p without the CRT going screwy. In Emulation Station it takes up the whole width, but in the Retropie splash screen and in games it’s extremely narrow and we can’t work out how to get around it.

    We haven’t changed any settings yet in RetroArch.cfg but we’re not even sure what to change.

    #111320
    Profile photo of petrockblog
    petrockblog
    Keymaster

    please post (via pastebin.com or similar) the output of

    
    tvservice -s
    cat /boot/config.txt
    

    for retroarch games, have you experimented with the aspect ratio settings in RGUI ?

    #111386
    Profile photo of r3dstar
    r3dstar
    Participant

    I’ll try that next. I’ll be able to get back into the lab on Friday for a few hours so I’ll give it a go then.

    Thanks.

    #111433
    Profile photo of dankcushions
    dankcushions
    Participant

    the game you have on the screen at the moment appears to be 1942, or something like that? those games are done at a vertical orientation (originally a TV on it’s side, i think).

    that said, if you’re using lr-mame2003 or lr-fba-next, go settings > video > change the ‘aspect ratio index’ to the one with “(1:1 PAR)”. one of these (i forget which) has a default aspect ratio setting that makes all these vertical scrolling games look messed up.

    the games will still have big black borders, but not as bad as in your shot 🙂 and it’ll be as they should look. if you don’t like the borders still you can mess about with the aspect ratio setting and stretch the games further 🙂

    #112175
    Profile photo of superbabyhix
    superbabyhix
    Participant

    I assume you’re using an HDMI to VGA adapter and running in HDMI_mode=8? If so, set the aspect ratio to 8:3. Also make sure you have integer scale on. As far as I can tell HDMI_mode=8 is 640×240 (or maybe 720×240), so you have to have the emulator double the pixel width.

    #115514
    Profile photo of quarterturn
    quarterturn
    Participant

    I have the same issue. I’m using an HDMI-component converter on a 25″ Sony TV. I found the following but haven’t tried it yet http://blog.petrockblock.com/forums/topic/change-resolution-in-retroarch-cfg/

    240p looks awesome on my almost-free Sony WEGA 25″. I tried out a GBS-8100 on a Sony broadcast monitor via 640×480 VGA as a comparison, and while it looks good, you’re stuck with an interlaced image.

    #115517
    Profile photo of quarterturn
    quarterturn
    Participant

    I have the same issue. I’m using an HDMI-component converter on a 25″ Sony TV. I found the following but haven’t tried it yet http://blog.petrockblock.com/forums/topic/change-resolution-in-retroarch-cfg/

    240p looks awesome on my almost-free Sony WEGA 25″. I tried out a GBS-8100 on a Sony broadcast monitor via 640×480 VGA as a comparison, and while it looks good, you’re stuck with an interlaced image.

    #115561
    Profile photo of quarterturn
    quarterturn
    Participant

    I’m stuck with a squeezed display, no matter what I set in retropie.cfg. Here’s what I have:

    video_aspect_ratio = “1.333333”
    video_aspect_ratio_auto = “true”
    video_windowed_fullscreen = “true”
    video_scale = “1.000000”
    autosave_interval = “0”
    video_crop_overscan = “true”
    video_scale_integer = “true”
    video_smooth = “true”
    video_threaded = “true”
    video_shared_context = “false”
    video_force_srgb_disable = “false”
    video_fullscreen = “false”
    bundle_assets_extract_enable = “false”
    bundle_assets_extract_version_current = “0”
    bundle_assets_extract_last_version = “0”
    bundle_assets_src_path = “”
    bundle_assets_dst_path = “”
    bundle_assets_dst_path_subdir = “”
    playlist_names = “”
    playlist_cores = “”
    video_refresh_rate = “59.950001”
    video_monitor_index = “0”
    video_fullscreen_x = “0”
    video_fullscreen_y = “0”
    video_driver = “gl”
    record_driver = “null”
    camera_driver = “null”
    location_driver = “null”
    threaded_data_runloop_enable = “true”
    dpi_override_enable = “true”
    dpi_override_value = “200”
    menu_driver = “rgui”
    menu_pause_libretro = “true”
    menu_mouse_enable = “false”
    menu_pointer_enable = “false”
    menu_timedate_enable = “true”
    menu_core_enable = “true”
    menu_dynamic_wallpaper_enable = “false”
    menu_boxart_enable = “false”
    menu_wallpaper = “”
    video_vsync = “true”
    video_hard_sync = “false”
    video_hard_sync_frames = “0”
    video_frame_delay = “0”
    video_black_frame_insertion = “false”
    video_disable_composition = “false”
    pause_nonactive = “true”
    video_swap_interval = “1”
    video_gpu_screenshot = “true”
    video_rotation = “0”
    screenshot_directory = “~/.config/retroarch/screenshots”
    aspect_ratio_index = “21”

    #115568
    Profile photo of dankcushions
    dankcushions
    Participant

    what emulator?
    what game? (is it all games?)

    #115572
    Profile photo of quarterturn
    quarterturn
    Participant

    I think it’s running mame4all (MAME in the emulator selection menu). It seems to be squeezed on all games. The front-end graphics appear to be in the wrong aspect as well, but at least stretched to fill the screen.

    #115573
    Profile photo of quarterturn
    quarterturn
    Participant

    Oh, the retroarch config menu itself looks about right when set to 8:3. But that’s about the only place.

    #115574
    Profile photo of dankcushions
    dankcushions
    Participant

    try going into https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand – to find out the exact emulator you are using. there are a couple of versions of mame4all, and 5 different mame emulators total!

    i’d also try another system to (NES/etc) which have a less variables to see if they work fine, which would rule out a system-wide problem.

    #115795
    Profile photo of quarterturn
    quarterturn
    Participant

    definitely mame4all. Seems like even the front end is ignoring the aspect settings. Here are some screenshots: http://imgur.com/a/RLlP1

    #116158
    Profile photo of quarterturn
    quarterturn
    Participant

    Alrighty, I gave up on 720×240 and went with the following in my /boot/config.txt:

    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt=320 240 60 1 0 0 0

    This provides 320×240 at 15 KHz.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar