2 player SNES issues

This topic contains 10 replies, has 3 voices, and was last updated by  alextaldren 3 years ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #2264


    There are some issues with 2 player games on SNES, such as Super Bomberman, the second controller only works if you hold down a button on the first controller. I’m using two SNES usb controllers, they work great on some games like Tetris 2 but on others they seem to act erratically. Anyone know a fix for this? I’ve been searching for hours with to no avail.



    I have the same issue with a football game but none of my other ones. My second controller only moves if I press a button on controller 1 at the same time.



    I was sent an email by Florian, who addressed this:

    12:23 AM (1 hour ago)

    This is a bug of the RetroArch SNES emulator.

    Currently, there is no easy fix for that. However, you could try some other SNES emulators (PiSNES or snes9x-rpi), which also come with the SD-card image and the RetroPie Script.

    Hope that helps,

    I’ll update this post as I learn more.



    Ok after looking around some more, I found that in the ~/.emulationstation folder is a file which points to the emulators called, “es_systems.cfg” it lists alternate emulator paths, but I haven’t gotten it to work yet. This is what I get after trying to run a rom after changing the emulator path:

    dylib_load() failed: “/home/pi/RetroPie/emulators/snes9x-rpi/snes9x: cannot dynamically load executable”.
    Failed to open dynamic library: “/home/pi/RetroPie/emulators/snes9x-rpi/snes9x”
    Fatal error received in: “load_dynamic()”

    Any ideas?



    Ok apparently I was doing it wrong. I was trying to swap out just the path to the emulator, when you have to swap out the entire “command” string. Got it to boot up into Snes9x, now to try to configure it.



    unfortunately, I have volunteered my raspberry pi for some work activities and won’t have access to it. I ended up removing games that didnt work well. Let me know if you have any success and I can try it when I get it back.



    Alright problem solved. The problem was with the emulator that RetroPie uses as the standard SNES emulator. To fix the issue I switched to using the pisnes emulator. Here’s how:

    Open ~/.emulationstation/es_systems.cfg

    Scroll all the way down till you find the part referencing SNES

    Below the COMMAND line there is a list of alternate emulators.

    Highlight and copy the line that says: COMMAND=/home/pi/RetroPie/emulators/pisnes/snes9x %ROM%

    Now replace the entire command string above with what you just copied.

    Save the file.

    Now navigate to:

    Open snes9x.cfg

    Scroll down to the Joystick section to modify the controls. They were way off originally. I basically just matched it to the retroarch.cfg mappings, and removed the extra functions.

    Not sure if it was necessary, but I added buttons for a second controller in this file:

    # Get codes from “jtest /dev/input/js1”
    # from package “joystick”

    Scroll down to the graphics section
    I changed:
    “DisplaySmoothStrech=1” to 0 (this made the games blurry)
    “MaintainAspectRation=1” to 0 (fills the screen)

    That’s it. Now emulation station opens SNES roms with PiSNES instead of PocketSnes. Confirmed that it has fixed 2 player issues at least with Super Bomberman. Hope this helps some people!



    Nice work! Can’t wait to try this out. The current emulator also had issues in some of the main menus of games. Had to use the “select”button instead of up and down to navigate the menu. Did you experience this issue as well or do you see it in the new emulator?



    Thank you! I was most definitely experiencing the main menu issues as well. So far this has worked like a dream. However I must append one my steps, “removed the extra functions from the joystick config” didn’t really do anything so I just remapped the extra functions as non existent buttons. The original mapping had set my usb snes controller R button as an exit button for the emulator which was annoying and redundant since Select+Start still exits the emulator. Other than that no issues at all this emulator is far superior. Let me know if you have any other questions. Enjoy!



    Good thing I wasn’t content with just switching emulators. I found an even easier fix someone mentioned in another post, I’ve tested it and confirmed that this fix works. https://github.com/retropie/RetroPie-Setup/issues/158



    Good thing I wasn’t content with just switching emulators. I found an even easier fix someone mentioned in another post, I’ve tested it and confirmed that this fix works. https://github.com/retropie/RetroPie-Setup/issues/158

    No offense, but the other topic is completely useless to someone who is new to Linux and Git. Which file do I open? How do I open it? I’m assuming Notepad won’t cut it. I’m pretty sure I can handle changing the one bit of code necessary, and then uploading the file to the proper directory on my Pi.

    So, can you break it down into logical steps for us newbies?

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss