2 issues on 3.4 that weren't there on 3.3

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! 2 issues on 3.4 that weren't there on 3.3

This topic contains 10 replies, has 7 voices, and was last updated by  dccelly 1 year, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #115069

    mikeveli20
    Participant

    1. When deleting a game using ES, ES quits directly to the command line but doesn’t restart. In 3.3 ES would automatically restart after performing such operation. I’m guessing the new functionality is because of the added ES menu options “Restart ES” and “Quit ES”. Looks like ES is calling the “Quit ES” function now instead of “Restart” like before. Is there any way to change this back to the old way?

    2. All “terminal text” will disappear at what seems to be a random time. This includes all of the text that shows before launching a rom (eg. Press the 0 button to configure, etc.). It’s just a black screen, but the functionality of pressing the 0 button still works. Same for the text that shows when shutting down the Pi. Difficult to tell now when the shutdown sequence has ended since it’s just a black screen. When I first boot up the Pi all the terminal text is there, but then after launching a couple games it just randomly seems to disappear. Any way to fix this?

    #115072

    jeffdamann
    Participant

    I have also noticed that when installing stuff from retropie setup script, you can get a black screen. However entering any input on the keyboard will give you display back.

    #115077

    petrockblog
    Keymaster

    I will look into the first issue – may need to change one of the function calls.

    the second issue is actually a Debian Jessie bug – the console blanker is still active. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=771161

    Try adding “consoleblank=0” to the end of the existing line in /boot/cmdline.txt

    or alternatively (safer as less likely to break booting by messing with cmdline.txt) add “setterm -blank 0” to /etc/rc.local (above the exit 0 line)

    #115078

    petrockblog
    Keymaster

    Looks like there is actually a problem in the EmulationStation delete functionality which is causing emulationstation to quit. It only worked before because we forced restart of ES, but it shouldn’t crash when deleting.

    #115079

    petrockblog
    Keymaster

    Known ES issue https://github.com/Aloshi/EmulationStation/issues/222

    Someone did make a fix so I will apply it on our branch https://github.com/Aloshi/EmulationStation/pull/346

    #115091

    mikeveli20
    Participant

    I did what you suggested by adding the line to /etc/rc.local. Seems to work so far.

    In regards to the Emulation Station fix, I guess there’s nothing I can do on my end to fix it in my current setup correct?

    #115129

    darksavior
    Participant

    I can add a few more problems. The boot time is a bit longer and the shutdown time is WAY longer if you have alot of roms. Almost 3 minutes. I have over 3000 roms on usb. The shutdown was much faster when I didn’t have any roms. Never had that issue on wheezy. I’ve been meaning to delete a bunch I don’t play..guess now’s a good time..

    Also, sometimes the snesdev script takes upto 30seconds to shutdown.

    #115141

    browner1980
    Participant

    Apologies I don’t have anything useful to contribute, but just wanted to reconfirm that I also have experienced all of the issues mentioned in this post since moving to 3.4:
    – Crash upon deletion of ROMs via Metadata menu
    – Random blank screen upon “ROM launch config screen”
    – Much slower boot time. I reckon it is at least twice as long to boot now, with same number of ROMs, in comparison to 3.3.

    #115182

    petrockblog
    Keymaster

    Rom deletion issue is known and confirmed and on our bugtracker.

    The blanker issue is known and there is a workaround above. We will sort that in a future image – it’s an underlying OS issue.

    Boot time is down to the OS, it’s quite possible Jessie boots slower – not a RetroPie issue though.

    Exiting emulatiomstation is actually a bugfix. Before no metadata was saved on exit – so data could be lost. Now it is, and meta data is always saved. Before it was saved if using quit, but not saved is doing shutdown / restart so we tried to make it more consistent. Unfortunately it does take a while to save if you have a lot of roms.

    #115222

    hardmanm
    Participant

    Since updating to 3.4 my Retropie wont shutdown.

    #116018

    dccelly
    Participant

    EDIT: Nevermind. All good.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/