2.6 pi2 Mame No Sound

This topic contains 11 replies, has 6 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 10 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #88046
    Profile photo of rotj83
    rotj83
    Participant

    Hi all,

    I just installed retropie 2.6 on my pi2. I had 2.5 and the sound with Mame worked. Now with 2.6 I get no sound with mame4all. I tried forcing stereo in the Mame.cfg … But that did nothing. Any thoughts?

    #88062
    Profile photo of andrewsi
    andrewsi
    Participant

    What kind of display are you using?

    If HDMI, have you uncommented/added “hdmi_drive=2” in /boot/config.txt? (Needed to get sound in screen modes other than the standard HDMI resolutions (e.g. 1280×720, 1920×1080, etc.)

    #88087
    Profile photo of rotj83
    rotj83
    Participant

    That fixed it! Thanks for the suggestion andrewsi!

    #88105
    Profile photo of spaceinvader
    spaceinvader
    Participant

    On the other hand, this have not resolved it to me, but I have changed the resolution for mame4all to CEA4 and the sound is here again.

    Only one matter, there is about 1 second of delay between the image and the sound, and the sound sometimes flicks.

    Any idea to solve this?

    Thanks in advance!

    #91128
    Profile photo of alucard63
    alucard63
    Participant

    Same problem here: I removed the “#” in front of hdmi_drive=2…but still no sound in dodonpachi…

    I actually use a pc monitor through HDMI, not a TV…

    In any case I don’t have any clue how to fix it.:-(

    Nobody found a solution?

    #91130
    Profile photo of spaceinvader
    spaceinvader
    Participant

    Hi!

    I finally have solved the sound delay in mame.

    I have changed the samplerate from 22500 to 40000 (not 44100) in mame.cfg

    And it works!

    Thanks.

    #91135
    Profile photo of alucard63
    alucard63
    Participant

    Just one question: how did you chnage the resolution of mame (and mame only) to CEA4?

    Thanks in advance?

    #91150
    Profile photo of spaceinvader
    spaceinvader
    Participant

    After selecting a game, a text message appears, if you press x or m at this moment, you enter in a menu where you can select the resoluction for this game of for all the games with this emulator.

    #91211
    Profile photo of alucard63
    alucard63
    Participant

    Thanks: it works fine now. 😉

    #91229
    Profile photo of spaceinvader
    spaceinvader
    Participant

    You’re welcome!

    #104997
    Profile photo of
    Anonymous

    I am a noob to the Raspberry pi and Retropie and i dont know where to add it. Do you have to write script on the raspberry, or edit it on the usb? If so where do i need to edit it? Just type it on the end?

    #105065
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Don’t know where to add what ? hdmi_drive ? that goes to /boot/config.txt (you can add it via the pi, or by editing on a PC)

    You should spend some time reading up on configuring the raspberry pi – http://elinux.org/RPiconfig and other sources. It will be easier to advise if you understand the basics.

Viewing 12 posts - 1 through 12 (of 12 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar