2.5 running slow on Pi 1 models?

This topic contains 6 replies, has 3 voices, and was last updated by  AmadhiX 2 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #87366


    Update: It’s slower “out of the box” because, unlike 2.4, 2.5 does not overclock by default. Just run raspi-config and set the overclock to Medium and everything should be back to normal. Just heed the warnings about overclocking. Thanks buzz!

    I loaded up the 2.5 image on my Raspberry Pi B (NOT A Pi2) and noticed that even older games ran much slower on the new revision. I thought surely that I was missing a step – some tweak I had made while running 2.4 that got it going smoothly.

    After messing with it for a while and having no luck, I decided to load up 2.4 again, retrace the steps I had taken with 2.5, and compare.

    Here’s what I did:
    1) Expand Disk + Configure Locale + Change Hostname.
    2) Update RetroPie Setup Scripts.
    3) Update RetroPie Binaries.
    4) Set mem split to 128 in /boot/config.txt. I set each of the lines for specific models to 128, just in case.
    5) Configure Controller. (I just dump in a premade cfg file.)

    At this point, I copied over a few SNES and Neo Geo games for testing, and then unplugged the ethernet cable. I’ve had problems that I attributed to Samba and/or FTP slowing down the Pi in the past, and unplugging seemed to eliminate that, just in case.

    using 2.4:
    Standard SNES games, Actraiser and SMW, are fully playable at this point, with no significant problems. Video, audio, and inputs all work great.
    Mark of the Wolves, in the /roms/neogeo/ folder and using the unibios, loads very quickly but runs slowly or hangs after the loading screen.

    using 2.5:
    Standard SNES games run but are laggy, with significant stuttering in the audio.
    Neo Geo takes a looong time to load, sometimes hanging during the load, and is slow with significant input lag if the load is succesful.

    6) My next step was to open es_systems.cfg and change the video mode for the FBA Neo Geo system command to 2.

    using 2.4:
    MotW now runs fine. There is a tiny bit of slow down once in a great while, but it is totally playable.

    using 2.5:
    MotW still load very slowly, if at all. If it does load, it feels a bit faster overall, but is still rendered unplayable by significant input lag.

    As I understand, the 2.5 revision was primarily to get Pi2 compatability. Maybe Pi1 compatability was broken somehow in the process?

    Has anyone had luck with 2.5 on a Pi1? Did I miss the memo about not using this revision for Pi1s? 😛



    Earlier images had overlocking enabled by default (medium overclock from raspi-config). This was not ideal, as it should be left to users to decide how much they want to overclock their set up.

    I guess you didn’t adjust the overclocking on the 2.5 image ?

    Also – for changing video mode – just press “m” before an emulator loads – no need to edit the es_systems.cfg



    I did catch the release notes, so I tried 2.5 at both a Moderate and a Medium overclock before reverting to 2.4. At Medium, both FBA and SNES were faster, but the SNES was still noticeably slower than it had been on 2.4, and FBA still had a lot of input lag.

    Before reverting, I poked around for info on overclocks and it seemed like people had been running SNES-era stuff fine with no overclock on previous builds? There’s no telling what people consider acceptable speeds though.

    I’ll give 2.5 another shot, if I get some time tonight, and report back. I’m all ears for other test/fix suggestions, and am really curious if anyone else has observed this.



    which emulators specifically ? which rom folders were you using ? (there are multiple snes emulators)



    I was using the “snes” folder and the “neogeo” folder, so whatever the default emulators are for those.

    I haven’t had a chance to give 2.5 another shot, but I’ll try to do that this weekend. I’m sure I tweaked a few other things before I tried the overclock, and that might have mucked up my results.

    Also, thanks for the ‘press m’ tip! That’s handy.



    I did notice that on Advmame on a Pi2 but using the old fb video rather than SDL (due to unrelated spinner input issue) turning on Vsync in any game dropped the speed to 50%. Not sure if that’s a new or old problem, but I discovered it just yesterday regardless. 🙂



    Alright, I finally got a chance to retest with 2.5. I’m happy to report that adding a Medium overclock to the above sequence seems to bring it up to 2.4 speeds, as expected.

    I must have done something between first testing 2.5 and setting the overclock on it that caused it to slow down. I have no idea what, but it’s not 2.5 itself that caused the problem, so crisis averted. The fact that no one else seems to have had a problem should be pretty good evidence too. 🙂

    Thanks, buzz!

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss