Reply To: Regular freezes with Raspberry 2&3

#121678

sabrecheeky
Participant

I am having similar issues, but mine is freezing within seconds mainly on PSP (both lr-PPSSPP and PPSSPP) and PS1 games on my new Pi3.

I had a nice set on my Pi2; NOOBS launcher with Ubuntu MATE, OpenELEC and RetroPie – a 10A 6 port (2.4A per port) USB power supply powering the Pi, Ethernet to Wifi adapter and 2.5in 500GB HDD. RetroPie (3.2 iirc) run great on that. All the games ran from the SD card, except the PSP and PS1 games from the HDD (all my own homemade rips which work great on the Pi2 and other machines).

I have tried to copy this set up on my new Pi3. Ubuntu runs like a dream, and OpenELEC similarly flawlessly, but this RetroPie issue has me stumped. I thought it might be the power supply so I bought an official (looking!) 2.5A supply – no fix. I changed over to an independently powered 3.5in HDD (3TB, one partition formatted to ext4 and mounted in fstab), still no luck. Tried a adding a heatsink too, no joy.

Reading other posts, perhaps there is a fair bit of variation in quality in the manufacturing of Pi3’s. I tried overloading (no overclocking, don’t do overclocking!) my Pi3 in Ubuntu to see if I could get it to freeze. I run all four cores at 100% (using ‘stress’) for half an hour with no ill effects, except a quite hot heat sink ><.

I’m not very technical, so any thoughts or ideas on where I’m going wrong would be greatly appreciated ^^