Reply To: Xiaomi BLuetooth on Retropie



i have that controller. It is quite nice especially for that price.
So basicly it works however the Bluetooth name of the controller is in chinese characters so you need a bit of configuration each time you use it.
I think the problem is upstream with bluez tools, but would be awesome if somebody could solve the problem.

So on Windows and Android and also on my Gnome Linux there are no problem regarding the chinese characters.
On retropie however you have to get in the console and to the following.
connect 00:00:00:00:00 (replace that by your bluetooth id)

Thats it after that you can start emulationsstation and it works perfectly.

Anybody has an idea to solve that??

I already tried installing all chinese characters (apt-get install fonts-arphic-*) and activate it in /etc/locale. I also tried updating fonts-cache (fc-cache -vf)
But so far nothing have worked that the controller works without the manual tweak.

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss