Reply To: 8Bitdo NES30 Pro hotkey problems in mupen64plus

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie 8Bitdo NES30 Pro hotkey problems in mupen64plus Reply To: 8Bitdo NES30 Pro hotkey problems in mupen64plus

#120773
Profile photo of slayer612
slayer612
Participant

With some further research I found a “solution” to the problem described above in THIS THREAD (which I didn’t see earlier, unfortunately). So in case anyone encounters the same problem:

The cause for the hotkeys not working is indeed the “wrong” button IDs, which are being written into mupen64plus.cfg automatically.

I disabled this feature in the /opt/retropie/emulators/mupen64plus/bin/mupen64plus.sh by commenting out the following lines:

# write hotkey to mupen64plus.cfg
 # iniConfig " = " "\"" "$configdir/n64/mupen64plus.cfg"
 # iniSet "${hotkeys_m64p[$i]}" "$bind"

Then I manually made my settings in /opt/retropie/configs/n64/mupen64plus.cfg by adding the button IDs shown by jstest:

# Joystick event string for stopping the emulator
Joy Mapping Stop = "J0B10/B11"
# Joystick event string for switching between fullscreen/windowed modes
Joy Mapping Fullscreen = ""
# Joystick event string for saving the emulator state
Joy Mapping Save State = "J0B10/B7"
# Joystick event string for loading the emulator state
Joy Mapping Load State = "J0B10/B6"

This fixed my problem – the hotkeys are working now.

I still don’t understand where those other button IDs retroarch uses are coming from though…

Skip to toolbar