Reply To: Keyboard numbers don't work in Doom

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Keyboard numbers don't work in Doom Reply To: Keyboard numbers don't work in Doom



When I tried to manually edit the configuration files I found that I couldn’t insert the “#” character, a.k.a the “pound sign” if your American or the “hash mark” if you’re a Brit. My keyboard region and layout were set to English-Great Britain instead of English-US; I’m American and have a US-style keyboard, so this caused some problems. To resolve it I set the root password and edited various Debian files to set my region, language, keyboard model, and keyboard layout to reflect US-English. I could finally edit my retroarch configs files and actually comment something out instead of getting a British Pounds Sterling symbol.

My keyboard now works correctly and I can edit text files, work at the command prompt, etc. to my hearts content. The keyboard numbers work as expected in text editors and at the command prompt, so Debian is happy. Still I couldn’t get the numbers to work in Doom (prboom) to select weapons.

So in looking through the Doom settings there are “next item” and “previous item” that move you through the menus and there are “next weapon” and “previous weapon” that are found much later in the settings. It’s important not to confuse them.

By default, the “next weapon” and “previous weapon” are mapped to “m” and “n”. I tried the “m” and “n” keys, and they don’t work in Doom either, despite the fact that the letters used to move, fire, and turn DO work. I tried booting with no game controller to see if it was interfering with keyboard controls. Nope, same symptoms with no game pad–no ability to select weapon from numbers or letters.

Editing the doom.cfg and telling it to use “button_2” or “button2” didn’t work.

I tried remapping the previous and next weapons to different keys from within Doom, and found that the “press enter to change” just exited me from the menu, but that I could press the “A” button on my game pad to get into the mappings. So using the “B” and “Y” buttons (logical buttons 2 & 3) I tried to remap the “M” and “N” keys. It worked, but the game said that these are the “shift” and “alt” keys.

So I can now select weapons, but the numbers don’t work and the keymappings are still essentially screwy. I’ve worked around my problem, but not understood it, much less solved it.

If anyone has ideas regarding how prboom, retroarch, and debian interactions might cause this, I’m all ears. Also, I’m assuming that the “ports” menu are for games ported to work directly on the Pi without an emulator layer. Someone please correct me if I’m wrong.

Thanks again for taking the time to read this. I hope it helps someone else who has the same problem.

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss