Reply To: Disable Launch Options screen

#115190
Profile photo of wilstorm
wilstorm
Participant

I am having different issue related to the same option:

“Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator).”

What I am using is an XBOX 360 wireless dongle as per these instructions:

https://github.com/RetroPie/RetroPie-Setup/wiki/setting-up-the-xbox360-controller

It works perfectly except for one small issue. Usually buttons A, B, C & D map to 0, 1, 2 & 3 on the XBOX 360 controller. When using wireless controller as per the instructions buttons A, B, C & D map to values 4,5,6 & 7.

I tried pressing all buttons on the controller but none of them will let me select/change the emulator. The keyboard works fine but I’m trying to access this feature via the controller so I don’t need a keyboard plugged in. Is there a way to change the button from 0 to 4 so it works with the wireless setup to change the emulator?

I see the code area you pointed out in the /opt/retropie/supplementry/runcommand/runcommand.sh file but I don’t quite understand what to change.

check for x/m key pressed to choose a screenmode (x included as it is useful on the picade)
clear
echo “Press a key (or joypad button 0) to configure launch options for emulator/port ($emulator). Errors will be logged to /tmp/runcommand.log”
IFS= read -s -t 1 -N 1 key </dev/tty
if [[ -n “$key” ]]; then
get_all_modes
main_menu
dont_launch=$?
clear
fi

if [[ -n $__joy2key_pid ]]; then
kill -INT $__joy2key_pid
fi

if [[ $dont_launch -eq 1 ]]; then
exit 0
fi

switch_mode “$mode_new_id”
switched=$?

[[ -n “$fb_new” ]] && switch_fb_res “$fb_new”

config_dispmanx “$save_emu”

Any help would be greatly appreciated.

Skip to toolbar