Yet Another Request for Help with SEGA CD / PCE CD

Home Forums RetroPie Project Everything else related to the RetroPie Project Yet Another Request for Help with SEGA CD / PCE CD

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of InsecureSpike InsecureSpike 2 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6975
    Profile photo of typh0id
    typh0id
    Participant

    I’ll start by apologizing because I KNOW there are numerous posts here with people asking how to get Sega and PCEngine CDs to run in RetroPie. Unfortunately, for every one I’ve come across I have tried the offered solutions and while the original posters generally responded “Thanks, that did the trick!” I still found myself unable to get the games to play.

    Let me break down what I’ve got going so far:

    1) I have .bin/.cue files for the games in the appropriate ROM folders (“megadrive” and “pcengine” respectively)

    2) I have edited es_systems.cfg to add .bin .BIN .cue .CUE to the entries for Genesis and Turbo Grafx 16.

    3) I have created a directory “/pi/home/RetroPie/bios” folder and in it I have put the following files (note that I have two sets of SegaCD bios files because I’ve seen different posts saying they should be named different things):

    bios_CD_E.bin
    bios_CD_J.bin
    bios_CD_U.bin
    eu_mcd1_9210.bin
    jp_mcd1_9112.bin
    us_scd1_9210.bin
    SYSCARD3.PCE

    4) I have edited the retroarch.cfg (All) to include the line: system_directory = /home/pi/RetroPie/bios

    5) I have altered the .cue files to exactly reflect the file name of the .bin letter for letter, taking case sensitivity into account.

    6) I have also (just for good measure) placed copies of the bios files in their respective systems’ ROM folders as well.

    After all of this, still when I select a SegaCD or PCEngineCD game (either with the .bin file or the .cue file) it shows the terminal screen loading the files but then immediately dumps me back into the EmulatioStation menu again.

    Am I overlooking something? I feel like I’ve followed all of the directions I have seen that have apparently worked for others but it still isn’t working for me. I would greatly appreciate any advice. Thanks so much!

    #6976
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    I’ll have a check to see how mine is set up

    edit: ok I have a few sega cd bios, in both the bios folder and segaCD rom folder,

    eu_mcd1_9210.bin
    eu_mcd2_9303.bin
    eu_mcd2_9306.bin

    Genesis_OS_ROM.bin

    jp_mcd1_9111.bin
    jp_mcd1_9112.bin

    SegaCDBIOS9303.bin

    us_scd1_9210.bin
    us_scd2_9306.bin

    hope this helps a little

    #7046
    Profile photo of typh0id
    typh0id
    Participant

    Ah! I believe the Genesis_OS_ROM.bin just may have been the issue. I’d never heard of needing that one but I have it copied to the Pi now and Sega CD is working perfectly! Thanks a ton!

    #7063
    Profile photo of typh0id
    typh0id
    Participant

    Well I guess I spoke too soon. Sega CD is indeed working great but TG16 CD is still not working at all…Not sure what to do since I have SYSCARD3.PCE in both the bios directory and the roms directory.

    UPDATE: So yeah this last one was just my own oversight…I still have trouble remembering how intensely case-sensitive Linux is…

    I renamed SYSCARD3.PCE to syscard3.pce and all is well…

    #7071
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    Well I guess I spoke too soon. Sega CD is indeed working great but TG16 CD is still not working at all…Not sure what to do since I have SYSCARD3.PCE in both the bios directory and the roms directory.

    UPDATE: So yeah this last one was just my own oversight…I still have trouble remembering how intensely case-sensitive Linux is…

    I renamed SYSCARD3.PCE to syscard3.pce and all is well…

    there are some pce cd rom bios about, 5 i think, not sure if its these you’d be needing? i’ve not got round to this yet

    CD-ROM System V1.00 (J).pce
    CD-ROM System V2.00 (J).pce
    CD-ROM System V2.01 (U).pce
    CD-ROM System V2.10 (J).pce

    Games Express CD Card 1993 (J).pce

    not sure how their supposed to be named either,

    please you got the Sega CD working

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar