Xboxdrv disables keyboard in Retroarch

Home Forums RetroPie Project Everything else related to the RetroPie Project Xboxdrv disables keyboard in Retroarch

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of spiwrx spiwrx 1 year, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #94350
    Profile photo of duglor
    duglor
    Participant

    Been setting up EmulationStation on the RPi2 with a GameStop Xbox 360 controller without too much hassle. It works fine with xpad bar the blinking LED which I decided to remedy by switching over to xboxdrv, plus I wanted to control Kodi with the controller but that isn’t a big deal itself.

    It fixed the blinking LED but now RetroArch menu can’t be opened or games can’t be controlled or exited via keyboard, nothing on it works not even F4.

    The Xbox buttons can’t be assigned either so although I can navigate through EmulationStation menus with the joypad/keyboard, once a game is loaded (no matter the emulator) there’s no response at all and exiting out using Putty to reboot the Pi is the only way.

    I’ve gone through numerous other topics here about hotkey_btn / reassigning keys in retroarch.cfg but nothing applies. Xboxdrv essentially disables the keyboard when any game from any emulator is started. So without it I can’t make any mappings for the controller unless I go through each and every emulator config file which I really don’t want to do.

    If I switch back to xpad, everything is hunky-dory bar the blinking LEDs. It’s wrecking my head and considering this is a new install I can’t understand what’s killing the keyboard functionality.

    #97116
    Profile photo of spiwrx
    spiwrx
    Participant

    Just experienced the same problem. Mine would play fine in PiFBA and MAME after XBOXDRV install but only “start” “select” and “A” (No Joy axis would respond) would work in other (retroarch) emulators. I Had to go back into and set retroarch controls again and it seems to be working fine now.

    Not sure that it mattered but I did the retro arch controls through:
    (Emulation station running) “Retropie” > “Retropie-setup” > “Set up” (Option 3) > “Configure input devices for retroarch” (Option 321)

    followed typical retroarch super fast input mapping and did a re-boot.

    Previously I had tried to do this straight from the option in the retropie menu off the emulator (“configure retroarch keyboard/joystick”) and it didn’t work.

    [System: Retropie3/PI2/wired 360’s. Overclocked “Turbo” with PiFba, MAme4all, NES, SNES, SMS, SMD, MX, Vectrex, Atari 2600, 7800 totaling 7000+ roms on a 32gb card. Most MAME and PiFBA are working for the given romsets. (scraped about 30% so far)]

    Still unresolved how to get the controllers working in MSX. Only working from keyboard now, but I’ve been to bust reconfiguring my MAME roms to 37b5 to research.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar