Xbox gamepad stopped working correctly after update to 3.3

Home Forums RetroPie Project Controller Configuration in RetroPie Xbox gamepad stopped working correctly after update to 3.3

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of reedy212 reedy212 1 year, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #112252
    Profile photo of firfurcio
    firfurcio
    Participant

    I just updated to RetroPie 3.3 from version 3.2.1 (through script update, then binary update from RetroPie-Setup), and after I rebooted, my Xbox 360 gamepad stopped working correctly. I can still use most of the buttons, but the triggers (LT and RT) won’t work anymore and will do weird things when I try to config input. The four lights around the Guide button won’t stop blinking, either.

    I tried to reinstall the Xbox drivers through RetroPie-Setup, but that didn’t do the trick.

    Does anyone know how to fix this? 🙁

    • This topic was modified 1 year, 4 months ago by Profile photo of firfurcio firfurcio.
    • This topic was modified 1 year, 4 months ago by Profile photo of firfurcio firfurcio.

    #112272
    Profile photo of buzz
    buzz
    Keymaster

    please update retropie-setup again, then disable and re-enable xboxdrv (will remove and recreate the launch configuration).

    • This reply was modified 1 year, 4 months ago by Profile photo of buzz buzz.
    #112275
    Profile photo of firfurcio
    firfurcio
    Participant

    Thank you very much for the response, Buzz! 🙂

    How do I disable/re-enable xboxdrv? Will “sudo apt-get remove xboxdrv” then reinstalling do the trick, or do I need to do something else? I… I’m kind of a newbie, here. ._.

    • This reply was modified 1 year, 4 months ago by Profile photo of firfurcio firfurcio.
    • This reply was modified 1 year, 4 months ago by Profile photo of firfurcio firfurcio.
    • This reply was modified 1 year, 4 months ago by Profile photo of firfurcio firfurcio.
    #112280
    Profile photo of buzz
    buzz
    Keymaster

    are you the same user with a thread open regarding this on reddit – because I don’t want to be responding to the same person in two places.

    #112282
    Profile photo of firfurcio
    firfurcio
    Participant

    Oh, you are the same guy who answered on Reddit? Haha, sorry about that. 🙂

    #112394
    Profile photo of reedy212
    reedy212
    Participant

    LINK TO REDDIT POST

    In case anyone wanders here with the same issue.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar