Xbox 360 wirless two player issues

Home Forums RetroPie Project Everything else related to the RetroPie Project Xbox 360 wirless two player issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of molloyaj molloyaj 2 years, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #91810
    Profile photo of molloyaj
    molloyaj
    Participant

    Hello all,

    I am using a Raspberry Pi 2 with the SD-card image for the RP2. I have successfully got one XBox 360 wireless controller working perfectly. I have tried multiple methods of getting a second controller working, but to no avail. The second controller works in the EmulationStation gui but not in any of the games (I’ve tried Mario Kart for the SNES and Sonic 2 doe the Genesis).

    The following is the contents of my rc.local.

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will “exit 0” on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    # Print the IP address
    _IP=$(hostname -I) || true
    if [ “$_IP” ]; then
    printf “My IP address is %s\n” “$_IP”
    fi

    xboxdrv –daemon –id 0 –led 2 –deadzone 4000 –silent –trigger-as-button –next-controller –id 1 –led 3 –deadzone 4000 –silent –trigger-as-button –dbus disabled –detach-kernel-driver &
    exit 0

    Any help with this grately appreciated!

    Best
    Andrew

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar