Xbox 360 Wireless controller problems

Home Forums RetroPie Project Everything else related to the RetroPie Project Xbox 360 Wireless controller problems

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: ,

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of clockwise clockwise 2 years, 5 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #82564
    Profile photo of clockwise
    clockwise
    Participant

    So I’ve spent a few hours now trying to get my wireless Xbox controller to work, and have been somewhat successful. The way I did this was like this:

    1. I installed the Xboxdrv using the following command: sudo apt-get install xboxdrv

    2. Added this line after Exit 0 in the /etc/rc.local: `xboxdrv –trigger-as-button –wid 0 –led 2 –deadzone 4000 –silent &
    sleep 1`

    3. I then added the cfg file for my controller according to this: `sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg`

    4. Success! The controller works, but the xbox button is blinking annoyingly. I can’t exit SNES emulator either so these are the next issues I tried to fix.

    5. I changed the cfg-file like this: sudo nano /opt/retropie/configs/all/retroarch.cfg and tried a few different lines for exiting the emulator. I’ve tried:

    input_exit_emulator_btn = “1″
    input_exit_emulator_btn = 1
    input_exit_emulator = “1″
    input_exit_emulator = 1

    Nothing works. (I do not have a ‘#’ at the beginning of the line). This is also the ONLY change I’ve done to the cfg-file.

    6. I gave up and felt like fixing the blinking button instead, so I did this: sudo nano /etc/modprobe.d/raspi-blacklist.conf and added blacklist xpad which resulted in that my Dpad doesn’t work, so I can’t move when playing SNES/NES…but all the other buttons seem to work, except that start/select are mapped to the trigger buttons. Before blacklisting xpad everything worked fine.

    So, this is where I’m at. Could use a little help now since I’ve looked through a lot of information thus far and nothing seems to help me.

    Threads I’ve checked:
    Blinking light
    http://blog.petrockblock.com/forums/topic/remove-xpad-and-use-xboxdrv-instead-to-stop-controller-light-flashing-constantly/

    Installing controller
    http://blog.petrockblock.com/forums/topic/xbox-controller-config/

    https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    Exit emulator
    http://blog.petrockblock.com/forums/topic/cant-change-emulator-exit-button/

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar