XBOX 360 Controllers mount location

Home Forums RetroPie Project Controller Configuration in RetroPie XBOX 360 Controllers mount location

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of tgilly tgilly 1 year, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #102820
    Profile photo of tgilly
    tgilly
    Participant

    All,

    I’m running RC1 and have everything working with two wireless 360 controllers except controlling the retropie-menu and lauching the emulator options when a game initiates.

    I believe this has to do with the fact that my controllers are “mounted” to /dev/input/js2 and js3. In my retroarch.cf, I have configured the joypad index so no issues there but I guess the retropie menu only takes js0 and js1 ?

    I’ve tried disabling the xpad module as I’m running via xboxdrv but that doesn’t seem to help. When I read the forums here, most people talk about disabling xpad BEFORE installed Xboxdrv, which I haven’t done.

    So in short : can I easily make sure that my Xbox360 controllers are mounted as js0/js1 ?

    Thanks

    #102969
    Profile photo of tgilly
    tgilly
    Participant

    I found the issue. I actually followed this guide (https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller) but instead of installed the “Xboxdrv” via the command line, I used the RetroPie Setup script. This actually besides installed the Xbox driver, also updates update.rc to run the driver.

    So long story short, I undid the actions I did as described in the guide above and my controllers were put on js0 and js1. I also blacklisted the xpad module to make sure no conflicts could come from that.

    #104835
    Profile photo of safurniss
    safurniss
    Participant

    Can you explain what you did to undo the actions in the guide?…

    I followed the YouTube video by Floob which references the above guide, although he is doing it to the older version…
    I’m trying to get the xbox controller to work correctly using V3 and a Pi2… my controller appears as js1 and not js0….

    What changes are required to get it to work as js0?

    Thanks.

    #105753
    Profile photo of tgilly
    tgilly
    Participant

    Just delete /etc/init.d/xboxdrv and run “sudo update-rc.d xboxdrv remove”

    If you also blacklist XPAD module, you should be good.

    Kind regards

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar