Xbox 360 controller only gets detected as Player 2

Home Forums RetroPie Project Controller Configuration in RetroPie Xbox 360 controller only gets detected as Player 2

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of axufstarisum axufstarisum 1 year, 8 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #104521
    Profile photo of axufstarisum
    axufstarisum
    Participant

    Hi everyone

    I’m using a RP 2 with Retropie 3. I followed Floob’s instruction in the Video RetroPie: Xbox wireless controller setup on Raspberry Pi.

    And I followed the steps in Setting up the XBox360 controller.

    My controller gets detected and everything is fine in emulation station. The problem is my controller seems to be player 2. If I check the inputs it is js1 (instead of js0…).

    When i configure the inputs in the Emulation Station it tells me that it detects 3 gamepads but I have only one connected to the Wireless Adapter.

    All this happens although I changed CONTROLLER_NUM=1 in the /etc/default/xboxdrv file.

    I tried this command I got from Github ./retroarch-joyconfig -o /opt/retropie/configs/all/p1.cfg -p 1 -j 1 (because I hoped it would tell the system that js1 is the player1) but my pi just responded this -bash: ./retroarch-joyconfig: No such file or directory

    Additionally I tried deleting the joypad configuration lines in /opt/retropie/configs/all/retroarch.cfg but nothing worked

    Thank you guys for your help!

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar