Xbox 360 Controller Mapping Problem

Home Forums RetroPie Project Everything else related to the RetroPie Project Xbox 360 Controller Mapping Problem

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 2 voices, and was last updated by Profile photo of morphiushell morphiushell 2 years, 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29987

    stereotyp

    Hi there,

    im about to completly freak out. i cant get the xbox controller to work. what i do is:
    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    then install the xboxdrv after that go to the point “Register RetroArch Controller”. after that only the d-pad works the a and b button work in the emnulators.

    then i tried:
    sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg
    after that only the d-pad works in emulator.

    im pretty sure retroarch uses the “XboxGamepad(userspacedriver).cfg” where everythings is mapped correctly, since i can exit the emulator with L and Select. but why the hell do the other buttons dont work? i cant understand it. that makes no sense to me. please please help me.

    #29988

    stereotyp

    this is the used config:
    input_device = “Xbox Gamepad (userspace driver)”
    input_driver = “udev”
    input_b_btn = “0”
    input_y_btn = “2”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-5”
    input_down_axis = “+5”
    input_left_axis = “-4”
    input_right_axis = “+4”
    input_a_btn = “1”
    input_x_btn = “3”
    input_l_btn = “4”
    input_r_btn = “5”
    input_l2_btn = “6”
    input_r2_btn = “7”
    input_l3_btn = “11”
    input_r3_btn = “12”
    input_l_x_plus_axis = “+0”
    input_l_x_minus_axis = “-0”
    input_l_y_plus_axis = “+1”
    input_l_y_minus_axis = “-1”
    input_r_x_plus_axis = “+2”
    input_r_x_minus_axis = “-2”
    input_r_y_plus_axis = “+3”
    input_r_y_minus_axis = “-3”

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “4”
    input_save_state_btn = “3”
    input_load_state_btn = “1”

    #29990

    stereotyp

    perhaps someone can copy me his working cfg for a 360 controller?

    #30014
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    If you’re using RetroPie image 2.x you don’t need to install xboxdrv. The config you need to edit is retroarch.cfg in /opt/retropie/configs/all/

    Here is my retroarch.cfg setup for a 360 pad: http://blog.petrockblock.com/wp-content/uploads/2014/02/retroarch_xbox360pad.zip

    If you have found the solution to your problem please mark the topic as resolved.

    #30038

    stereotyp

    i use 2.3. when i dont install the xboxdrv the controller doenst stop blinking at all 4 ports. the only way to solve that is to install the xboxdrv

    #30039

    stereotyp

    also i cant find that retroarch.cfg when i connect per ssh. folder structure seems diffrently

    #30075
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Yes you can use xboxdrv instead of xpad: http://blog.petrockblock.com/forums/topic/remove-xpad-and-use-xboxdrv-instead-to-stop-controller-light-flashing-constantly/

    retroarch.cfg location is /opt/retropie/configs/all/

    If you have found the solution to your problem please mark the topic as resolved.

    #30766

    stereotyp

    ok. what i did now:
    fresh image on sd. did nothing else as editing the retroarch.cfg in the folder you told me. mapped everything correctly…and still keys dont work. just a and b button work and strangly on the right analogue stick i can move left and right by pressing up and down.

    #30841
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Can you post the contents of retroarch.cfg in plain text

    If you have found the solution to your problem please mark the topic as resolved.

    #84649
    Profile photo of morphiushell
    morphiushell
    Participant

    Hey I am having a slightly different issue here is my .cfg file

    I found when I had mapped the the controller as mentioned above things ran ok but I didnt have use of the thumbsticks or could I exit or save. I came across these settings and now things work great but I did notice that for some reason i can no longer start a game at Mario Kart on the snes for some reason.

    Any Ideas

    #Player 1
    input_player1_joypad_index = “0”
    input_player1_b_btn = “0”
    input_player1_y_btn = “2”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “1”
    input_player1_x_btn = “3”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “11”
    input_player1_r3_btn = “12”
    input_player1_l_x_plus_axis = “+4”
    input_player1_l_x_minus_axis = “-4”
    input_player1_l_y_plus_axis = “+5”
    input_player1_l_y_minus_axis = “-5”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    input_enable_hotkey_btn = “8”
    input_save_state_btn = “5”

    input_enable_hotkey_btn = “8”
    input_load_state_btn = “4”

    input_enable_hotkey_btn = “8”
    input_state_slot_increase_btn = “7”

    input_enable_hotkey_btn = “8”
    input_state_slot_decrease_btn =”6″

    input_enable_hotkey_btn = “8”
    input_menu_toggle_btn = “3”

    #Player 2
    input_player2_joypad_index = “0”
    input_player2_b_btn = “0”
    input_player2_y_btn = “2”
    input_player2_select_btn = “8”
    input_player2_start_btn = “9”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “1”
    input_player2_x_btn = “3”
    input_player2_l_btn = “4”
    input_player2_r_btn = “5”
    input_player2_l2_btn = “6”
    input_player2_r2_btn = “7”
    input_player2_l3_btn = “11”
    input_player2_r3_btn = “12”
    input_player2_l_x_plus_axis = “+4”
    input_player2_l_x_minus_axis = “-4”
    input_player2_l_y_plus_axis = “+5”
    input_player2_l_y_minus_axis = “-5”
    input_player2_r_x_plus_axis = “+2”
    input_player2_r_x_minus_axis = “-2”
    input_player2_r_y_plus_axis = “+3”
    input_player2_r_y_minus_axis = “-3”

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar