XBox 360 Controller lags gameplay

Home Forums RetroPie Project Everything else related to the RetroPie Project XBox 360 Controller lags gameplay

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5555
    Profile photo of timm
    timm
    Participant

    Hi everyone,
    I have a problem concerning xbox 360 controllers (wireless) and retro-pie.
    I bought a receiver for my controllers and after following the instructions for installing the drivers and setting up the whole thing I can get the controllers up and running.
    Emulationstation will also detect the gamepad.
    When I run the snes emulator (didn’t try the others yet, because that’s the most important to me) the game lags very badly. It seems to run in slowmotion. When I let the emulator show the framerate it will go down to 45 fps while playing (don’t know if normal!?).
    In order to find out whether it’s the controllers I pulled the receiver while in game and voila everything works fine…

    Anyone having the same problem?
    From what I read a lot of people use the same controllers. I doubt you can not get them to work…

    By the way: I have the original receiver (at least it says microsoft on it, eventhough packaging was poor…) and I don’t use a powered usb hub.
    I also tried to overclock the pi, because at first I thought the controllers are somewhat cpu intense -> no difference.

    Thanks a lot!

    #5586
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Do you have the same problem in other emulators?

    If you have found the solution to your problem please mark the topic as resolved.

    #5681
    Profile photo of timm
    timm
    Participant

    Hi trimmtrabb, thanks for the reply!
    I just tried some gb and nes roms and they don’t seem to have that problem.
    I also tried different roms for the snes to find out whether it’s the rom, but they all have the same problem: Slow gameplay.
    As soon as I disconnect the xbox receiver the game runs at normal speed. When I put it back in it slows down immidiately…

    #5683
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    What power supply are you using? Anything lower than 1amp may cause issues with usb devices. You could also try editing your es_systems.cfg to use PiSNES instead (better performance) It’s commented out by default on the latest RetroPie image but just remove the hash’s and comment out the default Retroarch core to enable:

    nano /.emulationstation/es_systems.cfg

    Edit the SNES section so it reads like this:

    DESCNAME=Super Nintendo
    NAME=snes
    PATH=/home/pi/RetroPie/roms/snes
    EXTENSION=.smc .sfc .fig .swc .SMC .SFC .FIG .SWC
    #COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 2 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/pocketsnes-libretro/libretro.so --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/snes/retroarch.cfg  %ROM%"
    # alternatively: COMMAND=/home/pi/RetroPie/emulators/snes9x-rpi/snes9x %ROM%
    COMMAND=/home/pi/RetroPie/emulators/pisnes/snes9x %ROM%
    PLATFORMID=6
    

    Keyboard controls are default, to configure gamepad controls you need to edit snes9x.cfg located at /home/pi/emulators/pisnes

    If you have found the solution to your problem please mark the topic as resolved.

    #82841
    Profile photo of Gizmo
    Gizmo
    Participant

    Hi everyone,

    i have the same issue with this controller. SNES lags to slowmotion. I overclocked to 900 Mhz and the problem is solved for the SNES emulator but now i have the problems that the NES emulator lags anyway.

    Any ideas to solve this? I don’t want to overclock to 1000 Mhz because i’m afraid that my pi will damaged.

    Greetings

    #82854
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    What is the current rating of your power supply?

    If you have found the solution to your problem please mark the topic as resolved.

    #82865
    Profile photo of Gizmo
    Gizmo
    Participant

    5V / 2000 mA

    Update: I tested right now a 4A Power supply with an active USB Hub and powered the PI through this active USB Hub. Also the MS Wireless Receiver. But it’s not getting better. I overclocked to 950 MHZ and it’s gotten a little better but not fine. So i think the power supply is OK.

    Greetings

    • This reply was modified 2 years, 5 months ago by Profile photo of Gizmo Gizmo.
    #82888
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hmmm, do you experience slow down without the receiver plugged in?

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar