XArcade Solo for RetroArch Help

Home Forums RetroPie Project Everything else related to the RetroPie Project XArcade Solo for RetroArch Help

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 19 replies, has 2 voices, and was last updated by Profile photo of trizzane trizzane 2 years, 1 month ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #91790
    Profile photo of trizzane
    trizzane
    Participant

    Hello, thank you all for all of the work and knowledge to get my project to where it is at this point. Hoping I can cross the finish line soon.

    I am running XArcade Solo with Pi2. Previously I had one of the retro controllers and everything ran perfectly. Now, the xArcade is working fine to navigate ES and to play MAME, but I am unable to get RetroArch to recognize the Jotystick in anyway. If I try the ‘register retroarch Controller’, I get a message that no joystick is detected. If I try to adjust the config manually in the code to add the corresponding Xarcade button presses (From the manual where keystrokes are listed per button) I still get no response.

    when I ctrl f4 out of ES, I see messages appear that the values I entered for Retroarch are not valid and a few other lines I am not familiar with.

    So, what am I missing? I get a bit confused between which retroarch file I should be editing in which directory, but I thought I was in the right spot. Still odd to me that the Solo is not recognized at all, whereas the simple 6$ retro controller worked perfectly.

    I appreciate any help you can provide! thanks!

    #91801
    Profile photo of buzz
    buzz
    Keymaster

    the xarcade stick shows up as a keyboard doesn’t it ?

    Did you read http://blog.petrockblock.com/2014/06/01/xarcade2jstick/ ?

    retropie has this as an option in the setup menu.

    • This reply was modified 2 years, 1 month ago by Profile photo of buzz buzz.
    #91842
    Profile photo of trizzane
    trizzane
    Participant

    I can’t seem to reply. Not sure why.

    #91844
    Profile photo of buzz
    buzz
    Keymaster

    you just did ? 🙂

    #91846
    Profile photo of trizzane
    trizzane
    Participant

    if there a character limit? I cant paste in the larger message i wrote earlier.

    #91848
    Profile photo of trizzane
    trizzane
    Participant

    I will try to retype in pieces….
    -The link you sent, i tried and then nothing at all worked so i rolled it back, thinking maybe it was for TankStick only, and doesn’t for for Solo.

    #91853
    Profile photo of trizzane
    trizzane
    Participant

    I did the auto detect setup for ES and it worked perfectly. Did the same for MAME by pressing TAB when in a game, and it also worked in full.

    However, when i tried to ‘register retroarch controller’ it is not found at all and tells me no joystick detected. The stick seems invisible to retroarch completely. Do i need to change in the confg file that this is an xarcade device? Or ‘Joystick’ or is it just a keyboard? I am not sure where or how to do this, but what else could it be?

    #91858
    Profile photo of buzz
    buzz
    Keymaster

    you tried the option from the retropie menu as I suggested ? xarcade2jstick – The link was just for some information – try the option xarcade2jstick from the menu.

    The controller is not seen as a joystick to the system. It acts like a keyboard. if the above doesn’t work you can manually configure the keys in /opt/retropie/configs/all/retroarch.cfg

    #91895
    Profile photo of trizzane
    trizzane
    Participant

    Yep, that’s the first think i tried was to run that process from the menu, then try to register the stick for retroarch. It was not recognized at all nor did anything work in ES. At that point i thought maybe it was only for the tankstick and not the Solo, so i uninstalled it form the menu.

    Once i got ES and MAME running by manually configuring in ES and in MAME (Tab) i thought i was all good, but i cant find any way to get RetroArch to work.

    I did have it running fine with a generic retro/SNES type controller in the past, so maybe there is still something in the config file looking for that and not the xarcade stick? Since i manually configured it, im sure this is possible, but i have no idea what to check.

    Thanks for the help!

    #91898
    Profile photo of buzz
    buzz
    Keymaster

    Did you try my other suggestion ?

    #91902
    Profile photo of trizzane
    trizzane
    Participant

    I did that also, and it sits in that state now. I changed all of the rows in the config file to match the letters/keys supplied in the Xarcade manual that are pre-configured.

    #91905
    Profile photo of trizzane
    trizzane
    Participant

    Saying that, i have to guess something was left over from my old auto-detect setup form the retro controller that i didn’t change? since nothing i do on the Joystick is recognized at all (but is in ES and for MAME) that’s my only guess, but i don’t know what to even look for, or where.

    #91906
    Profile photo of buzz
    buzz
    Keymaster

    please post your retroarch.cfg somewhere for me to check. Make sure the xarcade service is disabled from the retropie setup menu too.

    #91907
    Profile photo of trizzane
    trizzane
    Participant

    Ok, will do. I will start a bit above where i made my changes in case something there needs to be adjusted. I am traveling for business so i will post it when i get home on Friday. Thank you for your help!

    #91908
    Profile photo of buzz
    buzz
    Keymaster

    the complete file would be best – please use a 3rd party site like pastebin and share the link. thanks.

    #91919
    Profile photo of trizzane
    trizzane
    Participant

    Buzz, i just realized, my lack of Linux might hurt me on this one. Can i open the Raspian GUI using ‘startx’ form the command line? Will i then be able to find a file broswer there to locate the config doc and easily be able to copy to pastebin as you mentioned? I haven’t booted to anything but ES in quite sometime. Thanks!

    #91935
    Profile photo of buzz
    buzz
    Keymaster

    not without installing a desktop first – desktop stuff have been removed from the image – unless you installed it on top of raspbian (or you have since installed a desktop environment).

    you can use “cp” to copy the file to ~/RetroPie/roms or something and then copy it off via the network share.

    #92039
    Profile photo of trizzane
    trizzane
    Participant

    trying to copy the file to roms folder, and im not bright enough for it to work. my command is:

    cp retroarch.cfg home/pi/retropie/roms

    i have tried other variations of this using the ~ for ‘home’ and i always get an error that the directory or file doesn’t exist. If i use only ‘roms’ for my destination i do not get an error, but nothing is copied. I also added ‘sudo’ in front thinking that might help, but no luck. What am i doing wrong?

    #92040
    Profile photo of trizzane
    trizzane
    Participant

    sorry, finally got it, will post link to it in a min

    #92041
    Profile photo of trizzane
    trizzane
    Participant

    http://pastebin.com/embed_js.php?i=YGFTTqiE

    ok, think that should work. let me know if not. You may note the spot where i entered the keys for the solo stick, i’m not sure if thats the proper spot or not. I saw a few other places where maybe it should have been entered? Thanks again for your time!

    • This reply was modified 2 years, 1 month ago by Profile photo of trizzane trizzane.
Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar