X-Arcade Dualstick problem since upgrading to 3.0

Home Forums RetroPie Project Controller Configuration in RetroPie X-Arcade Dualstick problem since upgrading to 3.0

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of mack505 mack505 1 year, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #105486
    Profile photo of Xenotome
    Xenotome
    Participant

    I love Retropie 3.0, but I’ve got a problem using my X-Arcade Dualstick. One of the buttons for player one and right on the 2nd players stick barely register (in emulationstation and emulators). I’m pretty sure I’ve read about similar problems before upgrading, but I can’t find it anymore and I’m not sure there even was a solution. Any idea how to fix this?

    It used to work fine in 2.6 (and I’m pretty sure in 3.0b2, too), I’m using Xarcade2Jstick and upgraded from 3.0 RC1 to final using the binary update in the Retropie setup.

    Thanks in advance!

    P.S.: Got a RaspberryPi 2 with the Pi2 Overclock setting.

    #105497
    Profile photo of buzz
    buzz
    Keymaster

    Nothing has changed in retropie relating to that, so it may be firmware / kernel / raspbian related.

    Have you tried without Xarcade2Jstick btw ? if the xarcade by default registers as keyboard presses, you can just use it as a keyboard – might work better – also we see where the problem initiates from.

    • This reply was modified 1 year, 7 months ago by Profile photo of buzz buzz.
    #105508
    Profile photo of Xenotome
    Xenotome
    Participant

    I tested again with Xarcade2Jstick disabled, but to no avail. Going to test it on another system to rule out hardware problems with the X-Arcade itself.

    I’m not using it all that much, maybe it was just a coincidence it stopped working after the update.

    #105803
    Profile photo of Xenotome
    Xenotome
    Participant

    Just a quick update: It really was just a coincidence. After reattaching all wires inside the X-Arcade, it works like a charm again. Sorry for wasting your time!

    #106076
    Profile photo of mack505
    mack505
    Participant

    Nothing has changed in retropie relating to that, so it may be firmware / kernel / raspbian related.

    Have you tried without Xarcade2Jstick btw ? if the xarcade by default registers as keyboard presses, you can just use it as a keyboard – might work better – also we see where the problem initiates from.

    I am trying to setup my X-Arcade Dual Joystick freshly but having issue with exiting emulators (MAME) back to ES. I am using it as a keyboard (Xarcade2Jstick/Xarcade-to-GamepadDevice.cfg didn’t work and jstest revealed that button 9 wasn’t represented).

    To what .cfg file, and what do I need to add to be able to exit back to ES?

    I tried this in /opt/retropie/configs/all/retroarch.cfg to no avail:
    input_enable_hotkey = x
    input_exit_emulator = space

    I have to have a keyboard hooked up and only escape works. Escape is not represented on the X-Arcade Dual Joystick though.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar