Wireless PS3 controller not working in emulators

Home Forums RetroPie Project New to RetroPie? Start Here! Wireless PS3 controller not working in emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of k-bert k-bert 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #103779
    Profile photo of k-bert
    k-bert
    Participant

    Well I had things working with a wired PS3 controller on my Raspberry Pi 2 Model B running Retropie 3.0, but that wasn’t good enough for me. I should have left it alone but I wanted to run wireless. So I plugged in an Asus USB-BT400 I had lying around and followed a setup video I found on youtube and I had the controller paired in a few minutes. The buttons were all mapped and then I fired up emulation station. I was able to set up the controller wirelessly there and things looked to be running great.

    I fired up a game in mame4all and none of the buttons worked. No problem, I pressed tab to get into the general inputs menu and tried to map the buttons there. None of the ps3 controllers buttons were being registered.

    I did a search on this problem and came up with this:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-Up-a-PS3-controller-for-mame4all-pi

    This is for the Retropie version 2.3, and as such things aren’t exactly in the same folders.

    My question is: do I still have to follow these steps or is there something obvious that I have missed?

    Thanks in advance!

    Cheers,
    K-bert

    #103874
    Profile photo of robertus
    robertus
    Participant

    maybe i understand your problem

    anyway i don’t have ps3 controller, but ps4 and i at the moment i didn’t get connection over bluetooth with my retropie… 🙁

    but your issue seems that your controller doesn’t work in game, but in menu?

    If in menu works, the problem is that for every emulator you need to map your controller, so start your rom, then press ps button and you have access to retropie menu, here you can go settings,device and map it.

    I’m going to mind, so the path (menu, settings and device) maybe isn’t right, but anyway try this way IF in retropie menu works

    #103993
    Profile photo of k-bert
    k-bert
    Participant

    I suppose that I wasn’t too clear…

    PS3 Controller works fine wired.

    In emulation station the ps3 controller works fine wired and wireless.

    In the NES and SNES emulators the ps3 controller works fine wired and wireless.

    In mame4all and advancemame the Ps3 controller works fine wired. I can not get it to work wireless. I tried pressing the PS button and nothing happened. I tried using a keyboard to get into the menu (TAB button) to map the buttons on the controller but none of the keypresses on the ps3 controller are registering. The controller light remains lit up as controller one.

    I’m sure that somewhere there is a simple setting that I have missed…

    Cheers,
    K-bert

    #103994
    Profile photo of k-bert
    k-bert
    Participant

    Also I should mention that I tried the fix in the link I posted above, but I can not find the minimal.cpp file.

    K-bert

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar