why do i have different hotkeys for each emulator

Home Forums RetroPie Project Everything else related to the RetroPie Project why do i have different hotkeys for each emulator

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.


This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of vitals vitals 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #88849
    Profile photo of vitals

    i have been at this all day cant figure it out!
    first i am using a raspberry pi 2
    and the newest image
    and xbox wireless controllers

    i have had hotkeys setup with old setup .but cant get it to work right on new image.
    i first use the defualt xpad driver for controllers
    and when into the retroarch.cfg and added the hot keys i wanted

    at the end of the config file i put

    input_enable_hotkey_btn = 6
    input_exit_emulator_btn = 7
    input_save_state_btn = 5
    input_load_state_btn = 4

    andi it worked fine for sega , nes , gamegear ,gameboy color ,gameboy , psx
    but didnt work for n64 or snes
    with snes i could exit and save and load state just not with the buttons I had defined
    and n64 nothing worked

    so i gave up
    and wanted to fix the xbox controller leds from flashing
    so i had to use the xboxdrv driver and set it up
    and blacklisted xpad
    restarted and leds were fixed and controllers working fine
    so than i went back to retroarch.cfg
    and add hot keys same as before
    now all the emulators but n64 have hotkeys but not the ones i defined and they are different for each emulator .
    I than erased the hotkeys i put into retroarch.cfg
    ran the ./retropie-setup.sh script
    and configured my controller in the setup menu
    and it saved to XboxGamepad(userspacedriver).cfg
    than i added the hotkeys to XboxGamepad(userspacedriver).cfg
    still nothing
    when into snes folder to see if the was a config file that was overriding my config and there was nothing
    I am out of options and read all i could fined on it
    please help

    Profile photo of vitals

    no one knows anything ,any suggestions would be helpful
    its like no matter what i do my defined hot keys works on some emulators and others default hotkeys override mine
    is there any way to remove the default hotkeys its not in the main config.cfg or in the emulators.cfg

    Profile photo of vitals

    evan if i disable hotkeys all together from the setup menu in the retropie script they still work

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar