vice emulation – vertical screen issues with a lot of games

Home Forums RetroPie Project Everything else related to the RetroPie Project vice emulation – vertical screen issues with a lot of games

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of nbk7 nbk7 1 year, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #108539
    Profile photo of nbk7
    nbk7
    Participant

    Hi,

    first I thought the vice emulator is running perfectly fine. But now I started to play a few games where the screen moves vertically instead of just horizontally.

    Some examples:
    the game SWIV only runs vertically. During the game the picture is constantly shaking like there is an earthquake. It is playable but it’s quite annoying.

    The game Myth runs horizontally but as soon as you jump the picture moves vertically. At this point the picture is starting to shake as well.

    turrican 1+2 obviously behaves similar as posted by cyborguk:
    http://blog.petrockblock.com/forums/topic/c64-vertical-scrolled-bad/

    The youtube videos I watched are obviously running vice on other plattforms where the issue doesn’t occur. I also tried different ROM versions of the same game. But the issue persists.

    Any ideas?

    Thanks and regards,
    nbk79

    EDIT:
    installed retropie version is 3.1

    • This topic was modified 1 year, 5 months ago by Profile photo of nbk7 nbk7.

    #108541
    Profile photo of buzz
    buzz
    Keymaster

    rpi1 or rpi2 ?

    did try try with and without dispmanx sdl mode for vice ? (See retropie menu in emulationstation)

    #108569
    Profile photo of dabone
    dabone
    Participant

    Try the same image using pal or ntsc.
    You may have the wrong version for the emulation mode.

    Later,
    dabone

    #108616
    Profile photo of nbk7
    nbk7
    Participant

    Thank you buzz an dabone for the fast replies.

    I found the setting that caused all this:
    Due to the fact that the C64 screen also got frames on top and on the bottom I initially set the video setting option “VICII Boarder Mode” in the vice menu to “none” because that would lead to a nice “almost” full screen mode on my 1920×1080 16:9 LCD. So I changed the option to “normal” and set the resolution to 640×480 in custom mode. Now I have little black frames on top and on the bottom but the vertical movement in the games is smooth now.

    I assume this is a bug because it also lead to some more unpleasant effects. For example the alien in the game Nebulus always walked a few inches on top of everything and I also had a few minor distortions in the screen in other games. Now that’s all gone – just don’t know if this is a platform related bug…

    Edit: I m using a rpi2 model

    • This reply was modified 1 year, 5 months ago by Profile photo of nbk7 nbk7.
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar