VIC 20 in Retropie?

Home Forums RetroPie Project New to RetroPie? Start Here! VIC 20 in Retropie?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 38 replies, has 4 voices, and was last updated by Profile photo of newpie newpie 1 year, 2 months ago.

Viewing 35 posts - 1 through 35 (of 39 total)
  • Author
    Posts
  • #114915
    Profile photo of newpie
    newpie
    Participant

    Hi, I am totally new to Raspberry Pi and have no knowledge of Linux/Unix. I am happy I found this page and got Retropie running tho the setup must be very easy for you guys.

    I love the variety of emulators but am missing my old VIC 20. I see that a part of VICE is integrated, emulating the c64, but the rest is not.

    I would really love to play my favorite childhood VIC 20 game SHAMUS via Retropie again.

    I saw a “Chameleon” retro gaming image but it doesn’t work on my Pi 2 and I’d rather use Retropie as I like it better.

    Is there a way for a complete novice to integrate the part of VICE that emulates this homecomputer?

    #114917
    Profile photo of herbfargus
    herbfargus
    Moderator

    What are the file extensions for vic 20?

    #114919
    Profile photo of newpie
    newpie
    Participant

    PRG and the Shamus catridge’s ending is CRT

    #114953
    Profile photo of herbfargus
    herbfargus
    Moderator

    Have you tried running them? It should work.

    #114979
    Profile photo of newpie
    newpie
    Participant

    I have and it doesn’t, though the c64 emulator in Retropie supports .CRT files … not the ones from the VIC 20 though.

    VICE is not one emulator but several. Each machine has a different emulator in VICE and the one for the c64 does not emulate the VIC 20. Sadly.

    The VICE-emulator for the VIC 20 is called “xvic”.

    For someone who has the knowledge I think it might be easy to put that one into the Retropie package together with the rest of the emulators. The c64-VICE is in there, so someone knows how to do it. I don’t know why the rest of the VICE emulators are not in there. Maybe no one thought that someone would like to play those old VIC 20 games. πŸ™‚

    • This reply was modified 1 year, 3 months ago by Profile photo of newpie newpie.
    #114985
    Profile photo of herbfargus
    herbfargus
    Moderator
    #114998
    Profile photo of newpie
    newpie
    Participant

    “This is accessed by pressing any key on the keyboard”

    I did and nothing happened! Took me half an hour to find out that you should press any key TOGETHER with the start button on your gamepad, not instead. πŸ™‚

    The emulator is indeed there, wow … but as soon as I told the thingy to start the game with the correct one, the next problem came up … more than one actually:

    1. The game needs a memory expension … which I found in the options menu could be given to it, but I doubt it makes much sense to try to load a game that’s too huge and afterwards plug in the memory expansion.

    2. The emulator automatically trys to load the game like a disc image ,8,1-style, but it is a cartridge which needs a reset to start. I found RESET as an option in the menu, but it didn’t start the game, because of the disc loading thingy.

    • This reply was modified 1 year, 3 months ago by Profile photo of newpie newpie.
    • This reply was modified 1 year, 3 months ago by Profile photo of newpie newpie.
    #115003
    Profile photo of gizmo98
    gizmo98
    Participant

    There is a option to select different vice emulators. There are six entries at the moment. If you launch a game press x or m.
    https://github.com/RetroPie/RetroPie-Setup/blob/master/scriptmodules/emulators/vice.sh#L73

    C128, CPET, PLUS4 and VIC20 are not really C64 variants. So i think we could add extra system entries for them.

    #115005
    Profile photo of newpie
    newpie
    Participant

    That would be great. I updated my post from earlier with the updated problems I am still having and would be grateful if you would still help me, though my initial question has been answered … thanks for that … would never be able to find those emulator entries on my own though!

    #115035
    Profile photo of newpie
    newpie
    Participant

    Ok, I got it to work .. still a few issues, but I can play SHAMUS now.

    For everyone who is interested and also a novice, here is how to do it:

    – copy your VIC20-cartridge rom via network into the c64 directory under ROMS
    – reset emulationstation
    – in the c64 part of Emulationstation highlight the game
    – press and hold any key on your keyboard and press START on your controller
    – in the menu that now pops up (this is the “Runcommand” menu) choose option 2 and tell it to pick “xvic” as emulator for this rom
    – start the game .. it will fail to load, as it will be loaded as a disc image
    – press start on your controller and in that menu configure the memory expansion and joystick settings
    – then you need to attach the catridge (first option on the top) and make your way through the directories until you find /home/pi/RetroPie/roms … there is your VIC 20 catridge file
    – then go to RESET and perform a SOFT RESET

    The game will start and is playable via controller.

    There is an option to save your settings but it doesn’t seem to work properly. It only saves the amount of memory expansion you chose, not the joystick settings and not the cartridge you chose. You will have to set those options every time you want to play.

    But .. it’s working and that’s what matters! πŸ™‚

    For future editions of Retropie it would be nice to have a seperate VIC 20 directory under ROMS and an extra entry in Emulationstation for the VIC 20 … and maybe the option to save all settings, not only a few.

    But for now, I am happy … topic resovled, thank you ^^

    • This reply was modified 1 year, 3 months ago by Profile photo of newpie newpie.
    #115037
    Profile photo of labelwhore
    labelwhore
    Participant

    There has got to be an easier way than that! Via some command line options and some edits to a handful of files, I bet we could get those to launch directly from the ES menu. It wouldn’t be too tough to make a theme for it too.

    Maybe I’ll take a crack at it later tonight.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115042
    Profile photo of newpie
    newpie
    Participant

    Would be awesome, thanks.

    #115043
    Profile photo of labelwhore
    labelwhore
    Participant

    Looks like there are a ton of command line options, so we should be in luck. πŸ™‚

    http://vice-emu.sourceforge.net/vice_3.html#SEC22

    http://vice-emu.sourceforge.net/vice_3.html#SEC23

    If you want to try it yourself, before I can get to it, this is basically what you’ll need to do:

    You’ll need to create a vic20 rom folder. You’ll need a vic20 folder in opt/retropie/configs, with an emulators.cfg file in there. You’ll need to copy the vic20 line from the c64 emulators.cfg file, and set it as the default option.

    Then you just need to add a new section to es_systems.cfg, and copy one of the current themes (probably c64) and rename it to vic20 and change the logo.

    We may need to mess around with the command line options within emulatpors.cfg for vic20 once it’s saved. That’s where the magic happens. If you can get a game to luanch a from the command line, you can use that command line to make the proper changes to emulators.cfg

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115045
    Profile photo of newpie
    newpie
    Participant

    Thanks for the help, I doubt that I could get all of that to work though, especially the changes in the cfg-files and the creation of the new section and logo. All I could manage would be to start the FileManager from the RetroArch section of ES, but after that I am pretty much lost, sorry.

    #115048
    Profile photo of labelwhore
    labelwhore
    Participant

    Well, once I post up the edited files and give in-depth instructions, you’ll have a better picture of what needs to happen to get this to work. It’s not difficult once you understand what it is that ES actually does and the file structure for the whole thing. Basically ES is just a front-end that runs things from command line, and organizes your roms.

    If we really wanted to make this easy, we could just add the new rom folder, and add a section to es_systems.cfg with the command line stuff right in there. But I like to follow the same file structure that exists when adding a new emulator, or breaking a feature out into a new category like this.

    You will have to get your hands dirty with some code to get this working, but it’s not too much work. The hardest part will be figuring out what the command line needs to look like to get the rom to launch directly.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 3 months ago by Profile photo of labelwhore labelwhore.
    #115051
    Profile photo of newpie
    newpie
    Participant

    Is there a way to access all the files and directories via network? I’d feel so much more comfortable, doing all that from my windows PC and TotalCommander.

    But I don’t see all the directories and files when connecting to the Pi.

    #115054
    Profile photo of labelwhore
    labelwhore
    Participant

    That’s what I do, it’s way easier. First I created a password for the root user. It’s recommended that you don’t do this for security reasons, but I threw caution to the wind and did it anyway. This avoids permission issues when editing files.

    from command line run:
    sudo passwd

    Then download filezilla or another FTP tool that allows SSH (SFTP). Find the IP address to your pi and connect to it in filezilla using the root user and your new password.

    I use textpad for editing files. When you save a new file, be sure to select UNIX as the system type, if you leave it as PC when you save, errors will occur in retropie. (This is only important when you save a new file, files on the pi will already be UNIX type.)

    https://www.textpad.com/

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 3 months ago by Profile photo of labelwhore labelwhore.
    #115056
    Profile photo of newpie
    newpie
    Participant

    Thanks, I will try that.

    #115057
    Profile photo of labelwhore
    labelwhore
    Participant

    I forgot to mention, if you upload any roms as the root user, you should run this afterwords to fix the owner:

    sudo chown -R pi:pi /home/pi/RetroPie/roms

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115058
    Profile photo of newpie
    newpie
    Participant

    I am sorry, I can’t even connect to the Pi. I set a new password like you said, but then I used several names as user name from “pi”, “raspberry”, “user”, “root”, “admin” .. I have no idea what the user name is .. google says it’s “pi” …

    You said “using the root user”, I suspected a word switch and tried “root” but it’s not working either. And yes, I do have the correct IP address πŸ™‚

    I did “ifconfig” and noted the IP but I can’t connect to the Pi with this IP, nor with \\RETROPIE from my browser. It only works when I seach the networks via TotalCommander and then select RETROPIE, that I can access the few directories that are permitted to be seen.

    • This reply was modified 1 year, 3 months ago by Profile photo of newpie newpie.
    #115060
    Profile photo of herbfargus
    herbfargus
    Moderator
    #115061
    Profile photo of labelwhore
    labelwhore
    Participant

    I missed “root” on the end of the passwd command. Sorry. It should have been sudo passwd root. (thx for the correction)

    and there’s this part now too, if you’re using Jessie:
    https://github.com/retropie/retropie-setup/wiki/FAQ#why-cant-i-ssh-as-root-anymore

    RetroPie 3.0 Jessie Builds:

    before setting a root password, the following must be edited

    sudo nano /etc/ssh/sshd_config

    look for

    PermitRootLogin without-password

    change it to

    PermitRootLogin yes

    then ctrl+x to save, next set your root password & restart your Pi

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 3 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 3 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 3 months ago by Profile photo of labelwhore labelwhore.
    #115065
    Profile photo of newpie
    newpie
    Participant

    Thanks for the links, I officially give up now that is more than I can do. I can’t edit a file from my PC I don’t have access to. πŸ™‚

    Thanks for all the help I will stick to the complicated method then .. at least there I know what to do! πŸ˜‰

    #115101
    Profile photo of labelwhore
    labelwhore
    Participant

    huh… apparently .prg files don’t seem to be automatically attaching like they are supposed to. From what I’m reading they should just start normally from ES as is after you select the correct emulator for the rom.

    …I’m still working on this though. I just found some .crt games to try.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115103
    Profile photo of labelwhore
    labelwhore
    Participant

    Congratulations newpie, I think you found a bug in VICE. According to the manual, games should be autostarting when launched the way you are starting them.

    I think we’ll need a fix to VICE before this will work correctly. For now, if you want to break out vic-20 games into their own section, I have all the instructions to do that except for the theme changes. I stopped when I ran out of command line options to experiment with.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 2 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 2 months ago by Profile photo of labelwhore labelwhore.
    #115109
    Profile photo of labelwhore
    labelwhore
    Participant

    It’s working now on my end.

    starting vic-20 games directly some ES – got it working πŸ™‚

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115120
    Profile photo of newpie
    newpie
    Participant

    Thanks for all the work you put in there … I answered in your new thread … sadly, I could not get it to work as I am still not able to access the needed files via network.

    • This reply was modified 1 year, 2 months ago by Profile photo of newpie newpie.
    #115140
    Profile photo of labelwhore
    labelwhore
    Participant

    I didn’t need any F keys, My controller worked from the get go. I hit start which brought up the emulator menu. For some reason, the right analog stick was set as controller 1, so I remapped the left one instead. From there, games just worked.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115143
    Profile photo of newpie
    newpie
    Participant

    I meant the F keys in the File Manager, those are not working for me, so I can’t copy, move, edit … or use the File Manager in any other way than browsing through the directories on the Pi. I also can’t access the menus on top of the File Manager window.

    Wouldn’t be a problem if I had access to the Pi via network … I wouldn’t wanna use the File Manager anyway, but my TotalCommander on my PC. ^^

    #115396
    Profile photo of labelwhore
    labelwhore
    Participant

    To save the controller mapping you need to create an empty file named sdl-joymap-VIC20.vjm in the /opt/retropie/configs/c64 folder. VICE will do the rest the next time you map your controller and save the joystick map from within the emulator.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 2 months ago by Profile photo of labelwhore labelwhore.
    #115405
    Profile photo of newpie
    newpie
    Participant

    Wow, the stuff you are finding out …thanks, will try that.

    #115430
    Profile photo of newpie
    newpie
    Participant

    The file is now there, but nothing will be stored in it. Tried it a couple of times, still 0 byte and my settings are gone, every time I start the game.

    #115443
    Profile photo of labelwhore
    labelwhore
    Participant

    Who’s the owner of that file? try this:

    sudo chown pi:pi -R /opt/retropie/configs/c64

    If it’s blanking the settings, we know vice is at least looking at the file.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115445
    Profile photo of labelwhore
    labelwhore
    Participant

    Wow, the stuff you are finding out …thanks, will try that.

    πŸ™‚ experimentation like this what I love to do.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115451
    Profile photo of newpie
    newpie
    Participant

    Well, I like to try stuff too, but always having to switch between monitors and keyboards, forwards and backwards and it’s not working .. it’s wearing me out and dampens the mood ^^

    Btw … it still didn’t work. The file is still 0 byte and the settings don’t get saved even though a VICE message pops up when I do ingame. After a restart the gamepad is again useless.

    All this owner settings paranoia stuff is so not my thing. πŸ™‚

    P.S. Is your homepage down or do you have a typo in the link?

Viewing 35 posts - 1 through 35 (of 39 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar