using retropie on a hdmi switch with auto-switch?

Home Forums RetroPie Project Everything else related to the RetroPie Project using retropie on a hdmi switch with auto-switch?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of cacophony555 cacophony555 1 year, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #115760
    Profile photo of mayner
    mayner
    Participant

    hi,

    i have to use a hdmi switch because my tv has only 3 hdmi ports, but i have 4 devices. i’ve connected my pc and the raspberry pi 2 (with retropie) on the switch. the switch supports auto switch: it switches to the port with the last turned on device. when i use port 2 (where retropie is connected) and turn on my computer is switches to port 1 (where my computer is connected). but this doesn’t work the other way around. it doesn’t switch to port 2 when i turn on the raspberry pi after my computer. auto-switch doesn’t work at all with retropie. whats wrong? do i need hdmi-cec?

    i’ve found something here http://blog.petrockblock.com/forums/topic/cec-remote-control/#post-87649, but i can’t find the 2 files configure.ac and Makefile.am.

    this (in the same thread) http://blog.petrockblock.com/forums/topic/cec-remote-control/#post-94617 also doesn’t work.

    what do i need? i don’t want to control the pi with my tv’s remote or the tv with the pi’s remote/gamepad. i just want to switch automatically the hdmi port of my hdmi switch.

    mayner

    #115763
    Profile photo of browner1980
    browner1980
    Participant

    I don’t have a solution, but just wanted to say that I too have this same issue. The Pi doesn’t seem to “trigger” the auto-switch, and I have to manually cycle the HDMI switcher to the Pi’s port.

    #115843
    Profile photo of riggs
    riggs
    Participant

    Same as browner1980, I don’t have the solution, but have you tried editing your config file and changing the CONFIG_HDMI_BOOST setting? This increases the HDMI signal strength – default is 0, max is 7. The raspberrypi.org site recommends trying a value of 4 if you’re having signal issues.

    There’s definitely something funny with the Pi’s HDMI. If I hook it up directly to my receiver (an Onkyo) it doesn’t work properly; I get signal drops every 30 seconds or so. However, routing it through a powered HDMI splitter first results in it working perfectly.

    #115878
    Profile photo of mayner
    mayner
    Participant

    but have you tried editing your config file and changing the CONFIG_HDMI_BOOST setting?

    i’ve set this to 11 (maximum), but it doesn’t work.

    i give up.

    #116088
    Profile photo of cacophony555
    cacophony555
    Participant

    Just use a usb switch to cut power to the pi completely and it will work fine with your auto hdmi switch. Here’s the one I use: https://www.adafruit.com/products/1620

    Just make sure to shutdown in emulationstation first to avoid corrupting the card.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar