USBGAMEPAD.CFG Problem

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #83566
    Profile photo of copious
    copious
    Participant

    First thanks to all who posted the how to guides on controller configs. I have the 2-USB retrolink controllers and have used retroarch to configure player 1. When I edit USBGAMEPAD.CFG for the second controller everything breaks.

    This is my current working single controller file

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    ##input_joypad_index = “0”
    ##input_joypad_index = “1”
    ##input_player2_device = “USB Gamepad ”
    ##input_player2_driver = “udev”
    ##input_player2_b_btn = “2”
    ##input_player2_y_btn = “3”
    ##input_player2_select_btn = “8”
    ##input_player2_start_btn = “9”
    ##input_player2_up_axis = “-1”
    ##input_player2_down_axis = “+1”
    ##input_player2_left_axis = “-0”
    ##input_player2_right_axis = “+0”
    ##input_player2_a_btn = “1”
    ##input_player2_x_btn = “0”
    ##input_player2_l_btn = “4”
    ##input_player2_r_btn = “5”
    ##input_player2_enable_hotkey_btn = 8
    ##input_player2_exit_emulator_btn = 9

    Am I supposed to register both controllers? Somehow?

    #83601
    Profile photo of Floob
    Floob
    Moderator

    When I use 2 controllers (that are the same), it seems to happily detect both with just the first set of lines. i.e.

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1″
    input_down_axis = “+1″
    input_left_axis = “-0″
    input_right_axis = “+0″
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”

    When you start a rom it should have some yellow text at the bottom of the screen confirming detection of the controllers.

    If you wanted to specify both controllers, I’d disable the autoconfig and just manually add the lines to the retroarch.cfg

    This may help a bit:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83648
    Profile photo of stynik
    stynik
    Participant

    I don’t think the player two line is needed. I am using a USB SNES controller and a PS3 controller and I didn’t need to put any player two lines in. Altho RetroPie thinks my PS3 controller is a Xbox controller due to some kinda driver mishap? But leave the .cfg files as default and should be fine.

    #83673
    Profile photo of copious
    copious
    Participant

    thanks all is working now, I suppose I read to much.

    On to another issue. the scraper error that the image can’t be scraped because of image size?

    #83687
    Profile photo of Floob
    Floob
    Moderator

    thanks all is working now, I suppose I read to much.

    On to another issue. the scraper error that the image can’t be scraped because of image size?

    Are you using the command shown here?
    https://github.com/sselph/scraper

    ‘./scraper -thumb_only’

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83701
    Profile photo of copious
    copious
    Participant

    thanks I will do this tonight.

    #83738
    Profile photo of copious
    copious
    Participant

    I am at a command prompt how do I execute

    $ GOARM=5 go build github.com/sselph/scraper

    I get an error everytime I do, I tried with sudo get-apt

    #83739
    Profile photo of Floob
    Floob
    Moderator

    Dont bother compiling it – just download the ready made rpi version here:
    https://github.com/sselph/scraper/releases

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar