USB Controller Mapping (SNES/N64) Issues

Home Forums RetroPie Project Everything else related to the RetroPie Project USB Controller Mapping (SNES/N64) Issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 10 replies, has 3 voices, and was last updated by Profile photo of likewhoa likewhoa 2 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #90579
    Profile photo of likewhoa
    likewhoa
    Participant

    Hello,

    It appears many people are having similar problems as myself. I’m a new user to RPi (I have the RPi2) + RetroPie. I’ve loaded and updated RetroPie just fine. I’ve gone through both of Floob’s Youtube Videos on how to configure a USB Controller, I’ve done the auto-config, I’ve manually double checked the controls are mapped fine in the retroarch config and I’ve manually set em in the SNES files, I’ve confirmed that the SNES emulator is set to automatically use the main RetroArch configurations as well. Sega Masterdrive works fine, but SNES and N64 emulators will not properly load the controls and the button mappings (for everything BUT the directionals/joysticks) are completely jumbled and the R2 button actually does the Reset command (which should take 2 buttons.)

    I’ve read through several dozen other threads, some people getting results, others not, and no solution has worked for me. I’m trying to set up a Sabrent 12 button controller. aka “MicrontekUSBJoystick” in the config file, but I’ve also had the same exact issue when I re-ran all the setups with my Wired XBox360 Controller.

    There is nothing I can find in any of the config files, in RetroArch or in either of the emulators, that shows the mappings of the buttons as they actually function within the games themselves. (Maneuvering ES’s menu with the controller works just fine, as does like I said, in Masterdrive).

    I will gladly provide any information that would be useful. Any help would be appreciated.

    Thank you.

    #90605
    Profile photo of Floob
    Floob
    Moderator

    Can you confirm the exact directory you have put your SNES roms in?
    It *must* be this for RetroArch to use them
    /home/pi/RetroPie/roms/snes/

    If they are in there (and not also in other folders), it should be using the retroarch config files in the same way that, for example, the Megadrive does.

    Are you using 2.6.0?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90662
    Profile photo of likewhoa
    likewhoa
    Participant

    I am using 2.6.0. I had them in the snes9x-retropie folder, moving them to the snes folder alleviated that control problem with snes. Thank you very much.

    However, the N64 controls issue still lingers. I have the roms in the retropie/roms/n64 folder. Should they be in the n64-mupen64plus folder instead?

    #90671
    Profile photo of Floob
    Floob
    Moderator

    This may help you with the N64 issue

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90692
    Profile photo of likewhoa
    likewhoa
    Participant

    I’ve switched the ROMs from the n64 to the n64mupen folder. I watched your video and want to add my controller’s mappings manually into the InputAutoCfg.ini file, but I’m not sure what to put for the name of the controller.

    The cfg file name is “MicrontekUSBJoystick.cfg”, but when I open the cfg file the first line reads

    input_device = “Microntek______________USB Joystick__________”

    with the underscores being spaces included. Would I just copy/paste exactly what’s within the quotations (spaces included) as the name into the InputAutocfg file?

    Thanks

    • This reply was modified 2 years, 1 month ago by Profile photo of likewhoa likewhoa. Reason: Spaces in device name were consolidated
    #90695
    Profile photo of Floob
    Floob
    Moderator

    Yes, I think that should do the trick.

    From memory I think a “lsusb -v” may also output this info for you.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90705
    Profile photo of likewhoa
    likewhoa
    Participant

    Excuse my naiveté, what do you mean by “lsusb -v” may output info for me?

    I’ve watched and followed through that video. I’ve now manually input my binds into the /opt/retropie/configs/n64/InputAutoCfg.ini file as per my attached screen shot, separated by a line between 2 other preset controller configurations. I’ve enter the button mappings as per the RetroArch joystick configurations, meaning (DPad L = axis(-0)) as opposed to how I see some other pre-set configs using (DPad L = axis(5-).

    This has not resolved the issue. The emulator still won’t recognize the controller mappings properly.

    Thanks.

    Attachments:
    #90814
    Profile photo of Floob
    Floob
    Moderator

    Can you post the file as an attachment here? (renamed to .txt)

    Do you have the equivalent file from /opt/retropie/emulators/retroarch/configs ?

    It should make it easier to map.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90845
    Profile photo of likewhoa
    likewhoa
    Participant

    I no longer see the attachment function on this thread.

    I’ve pasted the configuration from within the InputAutoCfg file for the controller along with the contents of the Controller’s configuration from /opt/retropie/emulators/retroarch/configs here; http://pastebin.com/DQtBzDEU

    I assumed I couldn’t just copy/paste from the RetroArch into the N64’s InputAutoCfg because the Retroarch mappings don’t include the C buttons.

    #90913
    Profile photo of ceuse
    ceuse
    Participant

    also make sure to set the mode to 0 in the mupen64config.cfg file. Gave me alot of headaches since it seems as long as mode 1 or 2 is present manuel configuration gets overwritten every start.

    #90943
    Profile photo of likewhoa
    likewhoa
    Participant

    Just tried setting the mode to 0 and no effect. Before and after I did so, now the emulator doesn’t recognize my controller at all.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar