Updating binaries stops!

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of apedroid apedroid 2 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #43560
    Profile photo of mttblue2
    mttblue2
    Participant

    While updating the binaries. The update gets to
    /opt/retropie/retropie /home/pi/RetroPie-Setup

    then “Kernel panic – not syncing: attempted to kill init! exitcode=0x00000007”

    Then it enters kdb and stops the update.

    #61697

    iago

    Also with the same problem, after download stuff and extract data it chrash on same point.

    I install retropie v2.3 and upgrade pacakages with apt-get update && apt-get upgrade.

    After that i execute the retropie_setup.sh script and crashes as descrived above.

    All work fine, and can play without problems, scrap data, etc. but this problem is still anoying me.

    thanks in advance

    #62761
    Profile photo of apedroid
    apedroid
    Participant

    Not sure about the kernel panic. Try removing overclocking and setting the memory split to 256. Also try a different powersupply if problem persists. You may also want to try updating your raspberry pi firmware with “sudo rpi-update”

    As for having problem with retropie_setup.sh after apt-get upgrade, try editing retropie_packages.sh and replace all (three) 4.7 references with 4.8. gcc-4.7 is removed for some reason, at least if you do an apt-get dist-upgrade, so it’s likely broken.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar