Unable to pair SNES 30

Home Forums RetroPie Project Controller Configuration in RetroPie Unable to pair SNES 30

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of nbk7 nbk7 1 year, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #112660
    Profile photo of blue-barracuda
    blue-barracuda
    Participant

    I just got myself a SNES30 8bitdo controller and am having issues getting it to pair with my machine. Here is some info on what I’ve gone through. I will admit up front I am not very fluent with Linux so I’ll do my best to give as much pertinent info as possible.

    I followed the setup procedure found here: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller

    I am able to see the controller when I run hcitool scan. When I run the pairing command:
    sudo bluez-simple-agent -c DisplayYesNo hci0 01:06:F3:71:60:0F

    I get:

    ERROR:dbus.proxies:Introspect error on :1.3:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    Traceback (most recent call last):
    File “/usr/bin/bluez-simple-agent”, line 102, in <module>
    path = manager.FindAdapter(args[0])
    File “/usr/lib/python2.7/dist-packages/dbus/proxies.py”, line 70, in __call__
    return self._proxy_method(*args, **keywords)
    File “/usr/lib/python2.7/dist-packages/dbus/proxies.py”, line 145, in __call__
    **keywords)
    File “/usr/lib/python2.7/dist-packages/dbus/connection.py”, line 651, in call_blocking
    message, timeout)
    dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    The controller is updated to the most recent firmware.

    I greatly appreciate any help, as I said I am a novice and really have no clue what’s going on here.

    #113350
    Profile photo of kaladin
    kaladin
    Participant

    I am having this exact same problem. Did you ever resolve it?

    #114313
    Profile photo of nbk7
    nbk7
    Participant

    I wrote a script to connect the controllers automatically:

    http://forum.8bitdo.com/thread-328-7-1.html

    Should also work for SNES30. Follow the instruction in #64. Hope it helps.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar